Mailinglist Archive: opensuse (1185 mails)

< Previous Next >
Re: [opensuse] Zypper died suddenly!
  • From: Tony <tonys@xxxxxxxxxxxxxxxx>
  • Date: Tue, 11 May 2010 16:10:54 -0500
  • Message-id: <4BE9C7DE.1010604@xxxxxxxxxxxxxxxx>

On 05/11/2010 10:43 AM, John E. Perry wrote:
I just tried my second "zypper up" after switching from "zypper dup" due
to the responses to my "Changing zypper command" message of last week.


zypper: error while loading shared libraries: cannot
open shared object file: No such file or directory

Now, yast won't start (dbus error), zypper won't start. I suppose I
might manually copy the library, if I knew where to get it and where to
put it. Is there anything I can do short of reinstalling suse? I do
have the opensuse ISO's on my hard drive, but since I haven't downloaded
Krusader since going to 11.2, I don't know how to get into it. Even if
the .619 version is there.

Keep in mind that I'm a fairly advanced _user_ with no more SA skills
than one learns by watching and asking questions on this list (embedded
systems engineer -- wasn't even sure what "systems administrator" meant
until subscribing here :-).

John Perry

I ran into the same problem when another instructor installed a new copy
of 11.2, this same error occurred each time the instructor installed 11.2.

A workaround, that worked for this time anyhow, is I created a symbolic
link pointing to the current
library, after that zypper and yast ran and I was able to post all
updates etc....

Looking in software management (before I posted the update(s)) for what
ever reasons libzypp was updated and zypper was not. Some where
something failed on the install, I never did see the full error, hoping
tomorrow to try the install again see if I can figure it out.

Hope this helps.


To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse+help@xxxxxxxxxxxx

< Previous Next >