Mailinglist Archive: opensuse (1581 mails)

< Previous Next >
Re: [opensuse] 11.2: nVidia MCP61 Ethernet (rev a2) still not working
  • From: Charles Obler <joyinstruggle@xxxxxxxxx>
  • Date: Mon, 22 Feb 2010 15:07:49 -0800 (PST)
  • Message-id: <222531.55772.qm@xxxxxxxxxxxxxxxxxxxxxxxxxxx>
Success!

My nVidia MCP61 now works! I have internet! I'm posting this from my new
machine!

The fix:

: I saw the "No configuration found for eth0" messages in
:: /var/log/boot.omsg
:: /var/log/warn

: I used google to find articles mentioning this message

: One article advised me to remove the MAC address tail from the name of the
ifconfig-eth0-id file in /etc/sysconfig/network , then reload forcedeth. E.g.:
:: mv -i ifcfg-eth-id-00\:32\:16\:9b\:d2\:34 ifcfg-eth-id
:: modprobe -l forcedeth
:: modprobe -r forcedeth
:: modprobe forcedeth

: The problem is that I HAD NO ifcfg-eth0-id file in /etc/sysconfig/network

: So I decided to build one, using the file in my existing system as a model,
and changing only the MAC address and the device name.

: First, I ran "ifstatus eth0", and got the following message:

eth0 device: nVidia Corporation MCP61 Ethernet (rev a2)
No configuration found for eth0

: Then I added two copies of the new file, one with the MAC tail and one
without. Then I ran "ifstatus eth0" again, and GOT A NEW MESSAGE!

eth0 device: nVidia Corporation MCP61 Ethernet (rev a2)
DHCP4 client NOT running
eth0 is down

: Well "down" is better than "dead"! Progress at last!

: Then I reloaded forcedeth, using the modprobe's, and reran ifstatus

eth0 device: nVidia Corporation MCP61 Ethernet (rev a2)
. . . is just beeing set up
eth0 is up
4: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP
qlen 1000
link/ether 00:24:21:b9:c1:43 brd ff:ff:ff:ff:ff:ff
inet6 fe80::224:21ff:feb9:c143/64 scope link tentative
valid_lft forever preferred_lft forever

: OMG! There must be something wrong: It's WORKING!

: I started Firefox (since I don't yet have Opera) and opened
http://www.antiwar.com . Woohoo!!!

-

BIG QUESTION:
: Why was this little ifcfg-eth0-id file NOT generated by the SuSE 11.2
installation?
: And why did Knopix and Ubuntu ALSO fail to generate it?










--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse+help@xxxxxxxxxxxx

< Previous Next >