Mailinglist Archive: opensuse (1660 mails)

< Previous Next >
Re: [opensuse] Very strange boot problem
  • From: Bob S <911@xxxxxxxxxxx>
  • Date: Thu, 10 Dec 2009 22:43:00 -0500
  • Message-id: <200912102352.2LQJM00@xxxxxxxxxxx>
On Wednesday 09 December 2009 03:03:12 Felix Miata wrote:
On 2009/12/09 02:04 (GMT-0500) Bob S composed:
.... (sdc8) Not sure what you mean about
the "root=position". You mean as an option on the grub menu? You
mean /dev/sdc8 ? or (hd2,7) ?

The kernel lines in your 11.2 menu.lst stanzas include something like:


While in the Grub menu part of the boot process, substitute /dev/sdc8 for
the .../yadas in your menu choice and report back what happens when you


I edited the menu.lst as you suggested. Changing /dev/disk/yadayada
to /dev/sdc8. Tried to boot and now it tells me it cannot find /dev/sdc8
rather than the /dev/disk/by-label it did previously.

Interestingly the line above it in the boot sequence also says it cannot
find /dev/sdc3 (which is the resume line) in menu.lst) and states ignoring
then continues on to the next line about not finding /dev/sdc8.

Oh, wait a minute. SUSE stupidly puts the showopts parameter after the
root= on kernel lines, and moves it back every time perl-Bootloader gets
run after manually putting it in the more useful pre-root= position. That
prevents you from seeing the root= section while in the GFX Grub menu.

To do what I wrote requires you exit the GFX Grub menu to the text Grub
menu to edit the kernel line root= section.
I have no idea what you are telling me here, not understanding the "SUSE way"
and do not know what you mean by the GFX Grub menu. If you mean editing
menu.lst that is easy.

I have tried every iteration of configuration I can possibly think of.

Bob S
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse+help@xxxxxxxxxxxx

< Previous Next >
Follow Ups