Mailinglist Archive: opensuse (1702 mails)

< Previous Next >
Re: [opensuse] Kernel Compiling
  • From: John Andersen <jsamyth@xxxxxxxxx>
  • Date: Thu, 10 Sep 2009 15:18:02 -0700
  • Message-id: <4AA97B1A.3020309@xxxxxxxxx>
David Haller wrote:

On Thu, 10 Sep 2009, Richard wrote:
On Thu September 10 2009 12:21:07 pm David Haller wrote:
On Wed, 09 Sep 2009, Richard wrote:
On Wed September 9 2009 5:39:41 pm David Haller wrote:
athelon:/usr/src/linux # make *config
That should have been a 'make cloneconfig' or 'make oldconfig' or
'make menuconfig'.

Yes, that is what I tried, the "*" in the above was saying I tried all the
varients of
"<*>config", eg, 'clone', 'old', etc. Sorry I wasn't clear.

Ah. Ok. I suggest 'make cloneconfig', that get's the config of the
running kernel out of /proc/config.gz.

ricreig@athelon:~> ls -ld /usr/include/asm*
lrwxrwxrwx 1 root root 26 2009-09-09 01:05 /usr/include/asm ->

Ok, that's why.

There's two symlinks used:

/usr/src/linux-obj/$ARCH/$TYPE/include/asm -> asm-x86
/usr/src/linux-obj/$ARCH/$TYPE/include2/asm ->

but there's _no_ symlink /usr/src/linux/include/asm, i.e. your link in
/usr/include also points to nothing.

So: remove /usr/include/asm and symlink the correct

But he should NOT be creating these symlinks.

The make process will take care of that as long as he has $ARCH and $TYPE set.
People should never have to run around making symlinks in distributed source.
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse+help@xxxxxxxxxxxx

< Previous Next >
Follow Ups