Mailinglist Archive: opensuse (1702 mails)

< Previous Next >
Re: [opensuse] experiment with ext4: can't mount?
  • From: Greg Freemyer <greg.freemyer@xxxxxxxxx>
  • Date: Wed, 2 Sep 2009 20:23:59 -0400
  • Message-id: <87f94c370909021723v1b981fedi2cef1e57e74288f8@xxxxxxxxxxxxxx>
On Wed, Sep 2, 2009 at 8:04 PM, Anders Johansson<ajohansson@xxxxxxx> wrote:
On Thursday 03 September 2009 02:01:14 Greg Freemyer wrote:
I thought I'd do some ext4 experiments.

I formated a ext4 loopback filesystem, but mount is failing:

# mount -t ext4 -o loop /home/ext4test.loop /mnt
mount: unknown filesystem type 'ext4'

Where can I get a version of mount that recognizes ext4?

try "-t ext4dev"

If that still doesn't work (it should) then do "modprobe ext4dev" and try

In 11.1, ext4 is still in its experimental stage. ext4 without the dev will
come in 11.2



I may be out of luck. This machine is running 11.1, but to experiment
with the latest ext4 stuff I downloaded a 2.6.31-rc7 kernel from and compiled it and booted into it.

It is running fine from my minimal testing. I also downloaded
e2fsprogs from the main devel's git repository and compiled /
installed it.

That gives me mkfs.ext4, but mount is still not working after trying
both of your suggestions.

I've got a laptop I'm not using much. Sounds like it is time to
install factory m6 on it if I want to continue this effort.

Greg Freemyer
Head of EDD Tape Extraction and Processing team
Litigation Triage Solutions Specialist
Preservation and Forensic processing of Exchange Repositories White Paper -

The Norcross Group
The Intersection of Evidence & Technology
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse+help@xxxxxxxxxxxx

< Previous Next >