Mailinglist Archive: opensuse (1558 mails)

< Previous Next >
Re: [opensuse] OpenSuse 11.1 can't login via global VNC config (* SOLVED *)
  • From: Andreas <maps.on@xxxxxxx>
  • Date: Sun, 16 Aug 2009 01:03:49 +0200
  • Message-id: <4A873ED5.6010506@xxxxxxx>
Well I found it on the net.

Yast sets localhost as target for the VNCs in xinetd.
In my local box "localhost" was in the IPv6-Line and was "nil".
I commented all the IPv6 stuff out and gave localhost back to 127...
That cured the problem. VNC gets a login provided the server is at runlevel 5.

Obviously gdm needs runlevel 5 and therefore a x-server.
Though calling vncserver on the console individually per user works on runlevel 3, too. So the whole runlevle 5 business is really just for asking for username and password. ... weired ...

on my OpenSuse 11.1 I activated VNC and switched the vnc2 in xinetd-config on with YAST.
So any user should now be able to use port 5901, 5902 and if he bothers 5801.

When I connect from a second machine I get the grey screen with the X mouse on all those ports.
So obviously the vnc basic connection is working.

I tried to read a lot on the net and found two tutorials and according to them it should fire up GDM and ask for credentials.
But no. Grey screen. Thats all I get.

Now I tried the individual configuration per user.
As normal user I created a vncserver setup in .vnc and this works.
I can login and work as intended.

There is just the gdm screen missing in the global approach even though yast comments out the |line
DisplayManager.requestPort: 0
in |/etc/X11/xdm/xdm-config.

Is there something broken in a fully updated OpenSuse 11.1 ?
I'm pretty sure it worked some time ago.


To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse+help@xxxxxxxxxxxx

< Previous Next >
This Thread