Mailinglist Archive: opensuse (1502 mails)

< Previous Next >
Re: [opensuse] Re: stubborn screen blanking under OS11.1 - Link SOLUTION
  • From: "LLLActive@xxxxxxx" <LLLActive@xxxxxxx>
  • Date: Mon, 06 Apr 2009 14:21:44 +0200
  • Message-id: <49D9F3D8.9050106@xxxxxxx>
Dave Plater wrote:
LLLActive@xxxxxxx wrote:

JC Francois wrote:

JC Francois wrote:


For a few weeks now my OpenSUSE 11.1 desktop PC has decided to blank the
screen after 6 minutes of inactivity. Nothing that I have tried so far
has managed to modify this behaviour.

Can somebody please suggest a place where to look for solution?

This problem is extremely irritating.



Someone else has a similar problem with a solution here:

Another (similar) problem could be (if you use KDE 3.5 with OpenSUSE 11.1):
I have one system that has similar behaviour - the difference is that it
flashes broad horizontal lines on the screen when the system starts,
before the first login. Automated Login is activated, but then after the
brad lines go away, the screen is blank. Pushing a key or moving the
mouse, a login screen appears of the screensaver. I have not yet logged
in at all! It goes straight from automated login into the screen saver
(blank). Once logged in, the screen saver does not start again.

What I noticed is that there are no screen savers to select from if you
try to set up one in KDE's Personal Settings -> Appearance & Themes ->
Screen Saver. If you have screen savers - skip the rest. If they fail,
read on:

I recall there was a missing screen saver directory problem in a
previous OpenSUSE 11.x version. On the system that works, I did the
manual link to the right directory for screen savers; on the one with
the strange behaviour not.

I use KDE 3.5 and not KDE 4.1 yet on OpenSUSE 11.1. Check if you have a
directory called /opt/kde3/share/applnk/System/ScreenSavers. My
installation did not have one. It was somewhere else, and had to be
copied here to get screen savers. See the workaround below if you do not
see screen savers.

Alexander R wrote:

On Sun, Mar 8, 2009 at 5:33 PM, Randall R Schulz <rschulz@xxxxxxxxx>

On Sunday February 15 2009, Marc Chamberlin wrote:

Sometimes I feel like it is just one $%@(! breakage after another in
Linux! I have not done anything other than ordinary updates, as they
come in, and now this time one of my systems no longer has any screen
savers showing in the list of the KDE -> Personal Settings -> Screen
Saver. I noted it when the screen saver failed to run and so went in
to see what the problem was.... The Setup and Test buttons are grayed
out/inoperative and no screen savers are listed. SO WHAT HAPPENED?

Did a reinstall of all packages related to screen savers, and now I
see that the screen savers are again running (randomly as I normally
select) BUT still no list of screen savers is being shown in the KDE
configuration tool.

This symptom is precisely what happened to me twice when I installed
some Gnome packages (I, too, use KDE 3.5). The first time I wanted the
Gnome control panel (or whatever it's called) the second time I wanted
Yelp (the Gnome help viewer). Both times I lost the list of screen
savers in the KDE configuration. Both times I had made it a point to
capture a screen snapshot of the list of automatic package changes tied
to the one Gnome package I wanted to add and that I could use that to
precisely back out the problematic packages. That, fortunately, did
restore my screen saver list.

I guess we can infer that the intersection of those two sets of packages
contains the problematic package(s). You can get those images here:


Am running KDE3.5 under SuSE11.1...

_workaround: _
sudo mkdir /opt/kde3/share/applnk/apps
sudo ln -s /opt/kde3/share/applnk/System/ScreenSavers

i'm using opensuse11.1, x64, default kde3.5
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse+help@xxxxxxxxxxxx

Million thanks Alexander and Randall for your replies and help. Yes
Alexander, your workaround works, too bad I have not seen any updates
come out to fix this breakage for other users...




My screen saver had also disappeared and was replaced by screen
blanking, I'm running factory and kde3 from build service, there's no
factory kde3 anymore. This mail prompted me to check it and the
workaround worked. Could have been the result of installing gnome
packages in my case as well.
Dave Plater

I looked at my system that I changed for the ScreenSavers to work.

I added a symbolic link where the ScreenSavers are expected by KDE 3.5
under OpenSUSE 11.1

as root: ln -s /opt/kde3/share/applnk/System/ScreenSavers

It works fine now.

To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse+help@xxxxxxxxxxxx

< Previous Next >