Mailinglist Archive: opensuse (3618 mails)

< Previous Next >
Re: [opensuse] WARNING! re latest update to OpenOffice from Novell -- RESOLVED ('mysteriously')
  • From: Basil Chupin <blchupin@xxxxxxxxxxxx>
  • Date: Sat, 31 Jan 2009 23:47:58 +1100
  • Message-id: <4984487E.3040308@xxxxxxxxxxxx>
Basil Chupin wrote:
Basil Chupin wrote:

Anders Johansson wrote:


On Saturday 31 January 2009 09:07:07 Basil Chupin wrote:



Just to be sure, do not allow YaST/zypper (or even smart) to update your
(32-bit) 11.1 installation of OpenOffice to the latest version - leave
it at 3.0.0.9-1.11.



It works on 11.1 as well. There were a few issues with dependencies which
need
to be reported to the packager though. e.g. OpenOffice_org-libs-gui,
OpenOffice_org-libs-core and OpenOffice-components do not seem to have
replacements in 3.0.1, so they should have been removed, but weren't. They
were still around at version 3.0.0.9, causing conflicts. But simply

rpm -e OpenOffice_org-libs-gui OpenOffice_org-libs-core
OpenOffice-components

made everything work again

Anders



Well when installing here all the *-extensions and the *filters-optional
RPMs are marked for deletion but they are not deleted and cause the
dependency problems. OK, they can be manually deleted but there is one
more RPM which simply cannot be removed because it is needed by some
3009 files (which will be replaced by the update anyway); this RPM is
OpenOffice_org-l10n-extras-3.0.0.9-1.11.noarch and it simply CANNOT be
removed because 'rpm -e' comes back and states that the damn thing is
not installed- when it is! :-) :-( .

And I will try removing the ones you mention above.



I deleted the files you mentioned above and OO3.0.1.2 now appears to work.

I'll now go and see which files WERE updated a few hours ago -- but I do
know that a number of 3009 files were still installed the last time I
looked (before I gave my self a break and watched a DVD :-) ).



<Shakes head in disbelief>

Just had a look in Software Management and found that the OO files have
been now updated to 3012 - which was not the case when I posted my
original message. Looks like the automatic daily Online Update 'jumped
in' and did some updating while I was watching the DVD.

(All I now need to do is to find out why I have been getting this for
the past several days:

#### YaST2 conflicts list - generated 2009-01-31 23:43:50 ####

compiz-kde4-0.7.8-28.1.i586 requires libplasma.so.2, but this
requirement cannot be provided
uninstallable providers: kdebase4-workspace-4.1.3-10.1.i586[repo-oss]
[ ] Following actions will be done:
downgrade of kdebase4-workspace-4.2.0-184.8.i586 to
kdebase4-workspace-4.1.3-10.1.i586
downgrade of kde4-kgreeter-plugins-4.2.0-184.8.i586 to
kde4-kgreeter-plugins-4.1.3-10.1.i586
downgrade of kdebase4-workspace-ksysguardd-4.2.0-184.8.i586 to
kdebase4-workspace-ksysguardd-4.1.3-10.1.i586
downgrade of kdebluetooth4-0.3-15.4.i586 to kdebluetooth4-0.2-12.38.i586
downgrade of kdebase4-workspace-devel-4.2.0-184.8.i586 to
kdebase4-workspace-devel-4.1.3-10.1.i586
downgrade of kde4-kwin-4.2.0-184.8.i586 to kde4-kwin-4.1.3-10.1.i586
downgrade of kdebase4-session-4.2.0-32.1.i586 to
kdebase4-session-4.1.3-2.1.i586
downgrade of kde4-kdm-4.2.0-184.8.i586 to kde4-kdm-4.1.3-10.1.i586
downgrade of kdebase4-runtime-4.2.0-76.3.i586 to
kdebase4-runtime-4.1.3-4.1.i586
downgrade of ktorrent-3.1.99+3.2beta1-20.20.i586 to
ktorrent-3.1.5-0.pm.2.i586
install ktorrent-3.1.5-0.pm.2.i586 (with vendor change)
openSUSE Build Service
-->
packman.links2linux.de
downgrade of kdepim4-4.2.0-86.3.i586 to kdepim4-4.1.3-3.13.i586
downgrade of kdeartwork4-screensaver-4.2.0-26.3.i586 to
kdeartwork4-screensaver-4.1.3-1.26.i586
downgrade of kdegraphics4-4.2.0-68.12.i586 to kdegraphics4-4.1.3-4.7.i586
downgrade of kdegames4-4.2.0-41.3.i586 to kdegames4-4.1.3-3.8.i586
downgrade of kdebase4-4.2.0-67.3.i586 to kdebase4-4.1.3-3.7.i586
downgrade of kdepim4-wizards-4.2.0-86.3.i586 to
kdepim4-wizards-4.1.3-3.13.i586
downgrade of kdenetwork4-filesharing-4.2.0-55.3.i586 to
kdenetwork4-filesharing-4.1.3-4.13.i586
downgrade of kdemultimedia4-4.2.0-41.3.i586 to
kdemultimedia4-4.1.3-4.14.i586
downgrade of kde4-kwrite-4.2.0-67.3.i586 to kde4-kwrite-4.1.3-3.7.i586
downgrade of kde4-kwikdisk-4.2.0-45.3.i586 to kde4-kwikdisk-4.1.3-2.12.i586
downgrade of kde4-ksnapshot-4.2.0-68.12.i586 to
kde4-ksnapshot-4.1.3-4.7.i586
downgrade of kde4-kshisen-4.2.0-41.3.i586 to kde4-kshisen-4.1.3-3.8.i586
downgrade of kde4-krfb-4.2.0-55.3.i586 to kde4-krfb-4.1.3-4.13.i586
downgrade of kde4-krdc-4.2.0-55.3.i586 to kde4-krdc-4.1.3-4.13.i586
downgrade of kde4-korganizer-4.2.0-86.3.i586 to
kde4-korganizer-4.1.3-3.13.i586
downgrade of kde4-ksudoku-4.2.0-41.3.i586 to kde4-ksudoku-4.1.3-3.8.i586
downgrade of kde4-kscd-4.2.0-41.3.i586 to kde4-kscd-4.1.3-4.14.i586
downgrade of kde4-kruler-4.2.0-68.12.i586 to kde4-kruler-4.1.3-4.7.i586
downgrade of kde4-kreversi-4.2.0-41.3.i586 to kde4-kreversi-4.1.3-3.8.i586
downgrade of kde4-kpat-4.2.0-41.3.i586 to kde4-kpat-4.1.3-3.8.i586
downgrade of kde4-kopete-4.2.0-55.3.i586 to kde4-kopete-4.1.3-4.13.i586
downgrade of kde4-kontact-4.2.0-86.3.i586 to kde4-kontact-4.1.3-3.13.i586
downgrade of kde4-konsole-4.2.0-67.3.i586 to kde4-konsole-4.1.3-3.7.i586
downgrade of kde4-konqueror-plugins-4.2.0-39.7.i586 to
kde4-konqueror-plugins-4.1.3-2.10.i586
downgrade of kde4-plasma-addons-4.2.0-51.3.i586 to
kde4-plasma-addons-4.1.3-5.21.i586
downgrade of kde4-okular-4.2.0-68.12.i586 to kde4-okular-4.1.3-4.7.i586
downgrade of kde4-kwalletmanager-4.2.0-45.3.i586 to
kde4-kwalletmanager-4.1.3-2.12.i586
downgrade of kde4-knetwalk-4.2.0-41.3.i586 to kde4-knetwalk-4.1.3-3.8.i586
downgrade of kde4-kmines-4.2.0-41.3.i586 to kde4-kmines-4.1.3-3.8.i586
downgrade of kde4-kmahjongg-4.2.0-41.3.i586 to kde4-kmahjongg-4.1.3-3.8.i586
downgrade of kde4-kgpg-4.2.0-45.3.i586 to kde4-kgpg-4.1.3-2.12.i586
downgrade of kde4-kget-4.2.0-55.3.i586 to kde4-kget-4.1.3-4.13.i586
downgrade of kde4-kgamma-4.2.0-68.12.i586 to kde4-kgamma-4.1.3-4.7.i586
downgrade of kde4-kfloppy-4.2.0-45.3.i586 to kde4-kfloppy-4.1.3-2.12.i586
downgrade of kde4-kfind-4.2.0-67.3.i586 to kde4-kfind-4.1.3-3.7.i586
downgrade of kde4-keditbookmarks-4.2.0-67.3.i586 to
kde4-keditbookmarks-4.1.3-3.7.i586
downgrade of kde4-kdnssd-4.2.0-55.3.i586 to kde4-kdnssd-4.1.3-4.13.i586
downgrade of kde4-kio_sysinfo-11.1.1-68.1.i586 to
kde4-kio_sysinfo-11.1-66.4.i586
downgrade of kde4-konqueror-4.2.0-67.3.i586 to kde4-konqueror-4.1.3-3.7.i586
downgrade of kde4-knotes-4.2.0-86.3.i586 to kde4-knotes-4.1.3-3.13.i586
downgrade of kde4-kmix-4.2.0-41.3.i586 to kde4-kmix-4.1.3-4.14.i586
downgrade of kde4-kmail-4.2.0-86.3.i586 to kde4-kmail-4.1.3-3.13.i586
downgrade of kde4-kmag-4.2.0-32.3.i586 to kde4-kmag-4.1.3-1.28.i586
downgrade of kde4-kio_kamera-4.2.0-68.12.i586 to
kde4-kio_kamera-4.1.3-4.7.i586
downgrade of kde4-kio_audiocd-4.2.0-41.3.i586 to
kde4-kio_audiocd-4.1.3-4.14.i586
downgrade of kde4-kcolorchooser-4.2.0-68.12.i586 to
kde4-kcolorchooser-4.1.3-4.7.i586
downgrade of PolicyKit-kde-0.2-20.32.i586 to PolicyKit-kde-0.2-6.3.i586
downgrade of kde4-kdialog-4.2.0-67.3.i586 to kde4-kdialog-4.1.3-3.7.i586
downgrade of kde4-kcalc-4.2.0-45.3.i586 to kde4-kcalc-4.1.3-2.12.i586
downgrade of kde4-kdf-4.2.0-45.3.i586 to kde4-kdf-4.1.3-2.12.i586
downgrade of kde4-kate-4.2.0-41.3.i586 to kde4-kate-4.1.3-2.8.i586
downgrade of kde4-kdessh-4.2.0-45.3.i586 to kde4-kdessh-4.1.3-2.12.i586
downgrade of kde4-gwenview-4.2.0-68.12.i586 to kde4-gwenview-4.1.3-4.7.i586
downgrade of kde4-ark-4.2.0-45.3.i586 to kde4-ark-4.1.3-2.12.i586
downgrade of kde4-akregator-4.2.0-86.3.i586 to
kde4-akregator-4.1.3-3.13.i586
downgrade of kde4-kdepasswd-4.2.0-67.3.i586 to kde4-kdepasswd-4.1.3-3.7.i586
downgrade of kde4-kaddressbook-4.2.0-86.3.i586 to
kde4-kaddressbook-4.1.3-3.13.i586
downgrade of kde4-dolphin-4.2.0-67.3.i586 to kde4-dolphin-4.1.3-3.7.i586
downgrade of ktorrent-lang-3.1.99+3.2beta1-20.20.i586 to
ktorrent-lang-3.1.5-0.pm.2.i586
install ktorrent-lang-3.1.5-0.pm.2.i586 (with vendor change)
openSUSE Build Service
-->
packman.links2linux.de
downgrade of kdebase4-nsplugin-4.2.0-67.3.i586 to
kdebase4-nsplugin-4.1.3-3.7.i586
downgrade of kde4-konqueror-plugins-lang-4.2.0-39.7.i586 to
kde4-konqueror-plugins-lang-4.1.3-2.10.i586
downgrade of libkdepim4-4.2.0-86.3.i586 to libkdepim4-4.1.3-3.13.i586
downgrade of libkdegames4-4.2.0-41.3.i586 to libkdegames4-4.1.3-3.8.i586
downgrade of libkcddb4-4.2.0-41.3.i586 to libkcddb4-4.1.3-4.14.i586
downgrade of libkcompactdisc4-4.2.0-41.3.i586 to
libkcompactdisc4-4.1.3-4.14.i586
downgrade of kdepimlibs4-4.2.0-1.13.i586 to kdepimlibs4-4.1.3-5.1.i586
downgrade of kdebase4-libkonq-4.2.0-67.3.i586 to
kdebase4-libkonq-4.1.3-3.7.i586
downgrade of kdegames4-carddecks-default-4.2.0-41.3.noarch to
kdegames4-carddecks-default-4.1.3-3.9.noarch
downgrade of libkdepimlibs4-4.2.0-1.13.i586 to libkdepimlibs4-4.1.3-5.1.i586
downgrade of libkonq5-4.2.0-67.3.i586 to libkonq5-4.1.3-3.7.i586
downgrade of kdegames4-carddecks-other-4.2.0-41.3.noarch to
kdegames4-carddecks-other-4.1.3-3.9.noarch
downgrade of libakonadi4-4.2.0-1.13.i586 to libakonadi4-4.1.3-5.1.i586
[ ] do not install compiz-kde4-0.7.8-28.1.i586

[ ] Ignore some dependencies of compiz-kde4




#### YaST2 conflicts list END ###


(Sorry for the long post - and for not starting a new thread.)


Ciao.


--
"I do not instruct the uninterested; I do not help those who fail to try. If I
mention one corner of a subject and the pupil does not deduce therefrom the
other three, I drop him."
Confucius


--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse+help@xxxxxxxxxxxx

< Previous Next >
Follow Ups