Mailinglist Archive: opensuse (3618 mails)

< Previous Next >
[opensuse] OpenSUSE 11.1, Dell Latitude E4300 & Sound :-(
  • From: Fabian Scheler <fabian.scheler@xxxxxxxxx>
  • Date: Fri, 30 Jan 2009 17:34:34 +0100
  • Message-id: <69dd805e0901300834l20aa0813r128ceae08e6e3a2@xxxxxxxxxxxxxx>
Hello everybody,

a couple of weeks ago I already told my woes regarding the same topic.
The only difference: I used OpenSUSE 11.0 instead of 11.1. I hoped
that my sound problems (I didn't have sound) just "go away" by
upgrading to the newest OpenSUSE version - unfortunately this was not
the case.

I have the following problem: I do not have sound at all :-( there is
nothing but silence ...

My Laptop:
Dell Latitude E4300
Chipset: Intel G45S
Sound: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 03)

I already tried the following things

- I played with the sliders
- I played with alsaconfig as root
- I configured the sound device several times

I also tried to uninstall pulseaudio completely, many KDE 4.2
packages, however, apparently depend on libpulse0, so a I can't
uninstall that lib as I am using KDE 4.2 and I don't want to change
this, as I like KDE 4.2.

nothing ...

The thing I am really curious about: (as with OpenSUSE 11.0) I
compiled and installed a vanilla kernel (2.6.27.{10,11,12,13}) that I
configured via 'make oldconfig' - with the kernel I compiled myself
sound just works ... When I install a 2.6.28.{0,1,2} vanilla kernel I
do not have sound, too. Is there something that breaks sound in the
2.6.28 kernel that has been backported to the OpenSUSE-kernel? I don't
know what impact that libpulse0-package has, but I don't think it is
the source of my problem, as sound shouldn't work with the vanilla
kernel in that case.

Has anybody observed similar problems in the meantime? I would really
prefer to use the kernel that is shipped with OpenSUSE because of
security fixes etc ... Where can I dig further?

Any comment is appreciated!

Ciao, Fabian

Further information that might be helpful

/etc/modprobe.d/sound:

options snd-hda-intel model=laptop position_fix=1
options snd slots=snd-hda-intel
# u1Nb.Q1mP6YkvExA:82801I (ICH9 Family) HD Audio Controller
alias snd-card-0 snd-hda-intel

dmesg | grep -i alsa yields no results
--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse+help@xxxxxxxxxxxx

< Previous Next >
This Thread
Follow Ups