Mailinglist Archive: opensuse (3609 mails)

< Previous Next >
[opensuse] Re: cannot mount boot partition during upgrade to sles 10 sp2
  • From: Jan Kalcic <jandot@xxxxxxxxxxxxxx>
  • Date: Fri, 30 Jan 2009 11:28:22 +0100
  • Message-id: <4982D646.4020300@xxxxxxxxxxxxxx>
Hi All,

Novell just published the solution. Fortunately seems I am the only one
to have this problem.

Anyway, just FYI: TID 7002461 (is about OES2 but it applies to SLES10 as
well)

[...]
Because the YaST installer is designed to use LVM by default, it looks
for the LVM partitions in the /dev/ device nodes path during an upgrade.
When EVMS is the volume manager of the system devices, the Linux path
for the /boot, swap, and / (root) partitions are under /dev/evms/, so
the YaST installer will not find the system devices. The YaST installer
looks for this information in the /etc/fstab file.
The YaST installer uses the boot.lvm boot loader when it attempts to
boot the device for the upgrade so, make sure to remove evms entry from
the boot line in /etc/fstab file before proceeding the upgrade/update
process.

Example:

in /etc/fstab, change the following before starting the upgrade/update
process:
/dev/evms/sda1 /boot
to
/dev/sda1 /boot
[...]

Regards,
Jan




Jan Kalcic wrote:
Hi All,

after searching for 3 hours I have not found any tips for this. Hope
someone here can help.

Upgrade to sles10sp2 from sp1 doing an in-place upgrade. Boot from DVD,
go ahead with the first steps of the installation and then select
"Update". However, when it finds and lists the root partition to update,
it gives me a warning I have never seen about an unknown partition which
cannot be mount and this is right the /boot partition. I could continue
with the installation but I don't.

Tried to mount it manually by both YaST and console but I get it does
not contain a valid superblock. Tried to fix it with e2fsck but it does
not solve. Actually it finds some errors on the filesystem, it fixes it
but when I run it again it still finds the same errors. I also tried to
recreate the filesystem but the same. It did not help.

Please any idea? The partition is ext3 and it's not part of the LVM
container on the same device which contains root and swap volumes only.

Thanks,
Jan

--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse+help@xxxxxxxxxxxx

< Previous Next >
This Thread
References