Mailinglist Archive: opensuse (3618 mails)

< Previous Next >
[opensuse] 10.2 still crashing; KDE freezes; command-line shutdown fails
  • From: Charles Obler <joyinstruggle@xxxxxxxxx>
  • Date: Thu, 29 Jan 2009 23:51:31 -0800 (PST)
  • Message-id: <343595.55911.qm@xxxxxxxxxxxxxxxxxxxxxxxxxxx>
I first posted this problem on 23 Dec 2008. Since then, it
has recurred every other day or so, sometimes more than once
a day. KDE freezes up. Windows fail to respond to close
requests. Window termination messages appear. System slows to
a crawl. KDE does not shutdown.

Today, I managed to enter a command-line shutdown. The command
was accepted and I got the "shutdown in 0 seconds" message. But
no further shutdown processing occurred.

As a diagnostic, I've created a bash script that saves ps output
in a file every three seconds. CPU usage and swap usage figures
do not seem excessive. Are there better diagnostics I can run?
If this is a loop in Xorg, is there a way to identify the block
of code it is in?

- - -

Here is my original message, dated 23 Dec 2008:

I have a severe intermittant problem and need help. I hope
I'm posting this report on the correct list.

I installed 10.2 about a month ago on a new computer. Two or
three times a week, I get locked out. It happened twice
yesterday. KDE first slows to a crawl then quickly freezes
with active screens incompletely rendered. Usually I lose
only the keyboard, but last night I also lost the mouse.
Either way, the system dies.

I'm sometimes able to press Ctrl-Alt-F1 just before the
freeze. Even "top", running in that console under root,
stopped updating its display. "xorg", with 0.7 CPU percent,
was at the top of the display when the lock-out occurred.

Sometimes I am able to close several KDE applications before
the complete freeze. Was not able to log out, however.



Here are my system specs:

X Window System Version 7.1.99.902 (7.2.0 RC 2)
Release Date: 13 November 2006
X Protocol Version 11, Revision 0, Release 7.1.99.902
Build Operating System: openSUSE SUSE LINUX
Current Operating System: Linux linux-8ez7 2.6.18.2-34-default #1 SMP Mon Nov
27 11:46:27 UTC 2006 i686
Build Date: 02 June 2008

SaX2 log : SaX2 version 8.1 - SVN Release: 1.49 2003/03/17

kde version: 3.5.5 "release 45.10"

uname gives: Linux h136 2.6.18.2-34-default #1 SMP Mon Nov 27 11:46:27 UTC 2006
i686 i686 i386 GNU/Linux



Monitor:

IBM ThinkVision
Model: L170
Microcode: L170 M-L170-110
Size: 1024x768
Aspect: 4x3
Refresh rate: 47.8kHZ 59Hz


Startup log:

boot.videobios start
Patching video bios Intel 800/900 Series VBIOS Hack : version 0.5.2

Chipset: 845G
BIOS: TYPE 3
Mode Table Offset: $C0000 + $4d2
Mode Table Entries: 25

Patch mode 3c to resolution 1024x768 complete
done
'boot.videobios start' exits with status 0



--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse+help@xxxxxxxxxxxx

< Previous Next >
Follow Ups