Mailinglist Archive: opensuse (3618 mails)

< Previous Next >
Re: [opensuse] unable to install acroread-8.1.3 in openSUSE11.1
  • From: Marcus Meissner <meissner@xxxxxxx>
  • Date: Tue, 27 Jan 2009 11:45:42 +0100
  • Message-id: <20090127104542.GA20671@xxxxxxx>
On Tue, Jan 27, 2009 at 04:11:42PM +0530, Arun Kumar Khan wrote:
System is openSUSE11.1 (x86) with KDE3/4,Gnome,XFce. OSS and Non-OSS
repos are enabled for Yast>Software Management.

Search for "acroread" brings up the rpm in the list but when I select it
and click on Apply, I get an error dialog box

"nothing provides libcrypto.so.9.7 needed by acroread-8.1.3 blah blah"

A quick check shows me that libcrypto.so.9.8 is installed on the system.
So I created a symlink libcrypto.so.9.7 linking to the libcrypto.so.9.8
file, executed "ldconfig" still no go. It still gives the same error
dialog box.

Here is a long listing of the libcrypto files.
<quote>
lrwxrwxrwx 1 root root 18 Jan 11 16:36 /usr/lib/libcrypto.so ->
libcrypto.so.0.9.8
lrwxrwxrwx 1 root root 18 Jan 12
00:02 /usr/lib/libcrypto.so.0.9.7 -> libcrypto.so.0.9.8
-r-xr-xr-x 1 root root 1455676 Dec 3 12:06 /usr/lib/libcrypto.so.0.9.8

# rpm -qf /usr/lib/libcrypto.so.0.9.8
libopenssl0_9_8-0.9.8h-28.4
</quote>

Any solutions welcome.

You need to install the compat-openssl097g RPM.

Ciao, Marcus
--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse+help@xxxxxxxxxxxx

< Previous Next >
Follow Ups
References