Mailinglist Archive: opensuse (3618 mails)

< Previous Next >
Re: [opensuse] dual boot issues
  • From: "Rajko M." <rmatov101@xxxxxxxxxxx>
  • Date: Mon, 26 Jan 2009 21:22:05 -0600
  • Message-id: <200901262122.05672.rmatov101@xxxxxxxxxxx>
On Monday 26 January 2009 10:30:01 am Dave wrote:
----- Original Message ----
On Sunday 25 January 2009 07:39:42 am Dave wrote:
I posted here a couple of weeks ago about dual booting 11.1 and Windows
7. I am still unable to boot into the Win7 partition from grub. I have
googled extensively with no success. The faq on the Grub site is way
outdated and still discusses issues with RH7 and using drives larger
than 8G. Has anyone had success dual booting openSUSE 11.1 and Windows
7. If not, would anyone be interested in helping me figure this one
out? I have set up SuSE machines to dual boot into Windows since SuSE
6.1 and Windows 95 but am stumped on this one.

Any help would be greatly appreciated.

Dave

You got couple of answers:
http://lists.opensuse.org/opensuse/2009-01/msg03415.html
http://lists.opensuse.org/opensuse/2009-01/msg03484.html
...
According to the few posts in the Internet, your Windows partition is
damaged. It happened after boot loader was installed in MBR, so try to
fix it using rescue console on Windows 7 disk. I guess that command is
'fixmbr' or 'fixboot', and then reinstall GRUB.

If it happens the same problem again please file bug report.

Success!

The boot sector was reported as corrupted by the Windows 7 repair
utilities. Windows 7 repaired the boot sector and rebooted. I expected to
go right back into windows after the reboot but instead got a pleasant
surprise and was back at the grub boot menu. I selected Windows, grub took
me to the Windows partition, and Windows booted without problems. I am now
back in SUSE via grub and would like to thank everyone for all of their
assistance. With the assistance of this mailing list I have been able to
resolve every issue that came up in 11.1 and now have a system that is the
best available anywhere.

Since the Windows 7 boot sector was corrupted during the install of grub
should I report this as a bug? After installing Win7 I was able to boot
successfully into Win7 until I installed grub.

Thanks again,

Dave

Good. Specially part of not overwriting existing MBR.

You should file bug report, even if you are not ready to play with
installation and repair process, it will bring the issue to developers
attention.

--
Regards, Rajko
--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse+help@xxxxxxxxxxxx

< Previous Next >
References