Mailinglist Archive: opensuse (3613 mails)

< Previous Next >
Re: [opensuse] Firefox not starting after 11.1 install
  • From: Dave Plater <dave.plater@xxxxxxxxxxx>
  • Date: Fri, 23 Jan 2009 10:34:49 +0200
  • Message-id: <49798129.4010604@xxxxxxxxxxx>
Basil Chupin wrote:
Dave Plater wrote:

Dave Plater wrote:


Randall R Schulz wrote:



On Thursday January 22 2009, Dave Plater wrote:




...

Thanks all, I couldn't find the lockfile but deleting the entire
contents of the ~/.mozilla/firefox directory and logging out and in
again sorted it out. Now all I have to do is retrieve my bookmarks
from backup.




In the future, just move the directory away from the place that makes it
special, don't actually eradicate it!






Regards
Dave P




Randall Schulz




I think firefox was running when I backed up the home directory. I'm
going to try restoring it with firefox running and see what happens.
Regards
Dave P




Success, I restored ~/.mozilla/firefox with firefox running and I've got
all my addons, bookmarks etc restored as well after restarting firefox.
The moral of the story :- don't backup home directory with firefox running.
Regards
Dave P



Sorry, but I see nothing wrong with making a backup of /home with
firefox running.

The only thing which doing so does - and you have been told/warned about
this in other posts - is that the backup will contain (shown in red
colour if you use mc to look inside the directory) the file "!lock" in
~/.mozilla/firefox/xxxxxxxxx.default which you need to delete otherwise
firefox cannot be activated again because it thinks that a copy is
already running. Same thing will happen to Thunderbird if that is being
used.

In any case, you do not restore ~/.mozilla/firefox but simply ~/.mozilla
because it is this directory which contains *all* of the firefox profile
details (for a particular user).

Ciao.




I looked for lock but couldn't find it but now with firefox running it's
present with the ! which in mc means a link to a nonexistent file
although its shown as a link to 127.0.0.2:+22439. I've just searched my
backup again and the file doesn't exist. BTW I think thunderbird was
also running when I copied my home directory to backup but everything
went smoothly.
Regards
Dave P

--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse+help@xxxxxxxxxxxx

< Previous Next >