Mailinglist Archive: opensuse (3613 mails)

< Previous Next >
[opensuse] My first 'Update' 10.3-11.0 - Won't boot - damn disk-by-id problem - help?
  • From: "David C. Rankin" <drankinatty@xxxxxxxxxxxxxxxxxx>
  • Date: Wed, 21 Jan 2009 16:54:09 -0600
  • Message-id: <4977A791.4060203@xxxxxxxxxxxxxxxxxx>
List,

After only doing fresh installs since 8.0, I tried my first 'Update' on
a 10.3
box going to 11.0. Looks like the update succeeded, but it left me unable to
boot.

Grub is installed on the right partition, but after booting 11.0, it
gets to
the place where it is:

waiting on required device /dev/long-string-of-id-stuff-part2

and then bombs. '/' is /dev/sda2, '/home' is /dev/sda3 with swap on
sda1.

I have tried using the rescue disk and:

mount /dev/md1 /mnt
mount /dev/md0 /mnt/boot
mount /dev/md2 /mnt/home
mount -o bind /dev /mnt/dev
mount -o bind /proc /mnt/proc
mount -o bind /sys /mnt/sys
cd /mnt
chroot /mnt

use Yast boot loader config and save, then it bombs again at the same place,

I have also tried editing the grub entry at the first boot screen and
changing
the disk-by-id string to /dev/sda2. Boot dies at the same place:

waiting on required device /dev/sda2

So I'm sort of stumped. I recall a rash of problems with disk-by-id,
but I
didn't save the solution. I'm committed to make this update work. Can anyone
share the fix with me? Thanks!


--
David C. Rankin, J.D.,P.E.
Rankin Law Firm, PLLC
510 Ochiltree Street
Nacogdoches, Texas 75961
Telephone: (936) 715-9333
Facsimile: (936) 715-9339
www.rankinlawfirm.com
--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse+help@xxxxxxxxxxxx

< Previous Next >