Mailinglist Archive: opensuse (3609 mails)

< Previous Next >
Re: [opensuse] a proprietary dvd don't play with xine, but OK with vlc
  • From: Tamas Sarga <tamas.sarga2@xxxxxxxxx>
  • Date: Wed, 21 Jan 2009 21:08:08 +0100
  • Message-id: <497780A8.6030405@xxxxxxxxx>
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Basil Chupin wrote:
Tamas Sarga wrote:
M. Skiba wrote:
Am Dienstag, 20. Januar 2009 22:19:08 schrieb Tamas Sarga:
I borrowed the Batman Dark Knight dvd.
We don't wanna know where you got it from, you just have it :-)

It is the original official dvd borrowed from one of my friends for
private usage :) Really.

I tried to play it with kaffeine, than xine. It starts to use all
of the
physical RAM then the swap space, not for caching, but the application.
And nothing happened, there isn't player window or anything. I had to
kill the app.
With xine it is OK.
With xine or with vlc?

Oh my god, I'm crazy, so it is OK with vlc.

My problem is that I'd like to fill a bug report, but I'm absolutely
clueless, what should I write into. I use Kaffeine usually and I've
never got such problem with it. In addition I have to get the dvd back
tomorrow, so I can't debug it further.
You could open a bug report (but don't forget to state your versions
(numbers) ). I.e. do you use the normal kaffeine package from
openSUSE or the
packman version, libdvdcss installed or not etc.
I have the packman version of kaffeine, xine and libdvdcss, and I have
vlc from the vlc repo.

Use k9copy - set to DVD size 8.0GB - and transfer the DVD to a folder on
your harddrive; then use kaffeine (File>Open Directory) to open the
directory where the copy of the DVD is sitting (it'll be something like
/Knight/dvd).

If k9copy has a hernia trying to copy the DVD then there is some
hanky-panky going on with the (original) DVD in which case you could
then try and see if it will play through your DVD burner - assuming that
you have one; the burner may be able to read track/s which the CDROM/DVD
player isn't able to access.

Ciao.


Hi,

I tried to copy the dvd with k9copy, but it produced the same symptom as
xine, so I created an image by k3b. But the image can not be played with
xine, with kaffeine, with mplayer nor with vlc. So everything goes wrong
with the image, but the disc can be played with vlc.
I think this is not a bug of xine, or mplayer rather an unstandard copy
protection. What do you think?
K3b didn't complain about anything while created the image.

Vlc says for the image:
libdvdread: Found 9 VTS's
libdvdread: Elapsed time 0
libdvdnav: Language 'en' not found, using '��' instead
libdvdnav: Menu Languages available: ��
libdvdnav: Language 'en' not found, using '��' instead
libdvdnav: Menu Languages available: ��
libdvdnav: Language 'en' not found, using '��' instead
libdvdnav: Menu Languages available: ��
[00000447] a52 decoder: A/52 channels:2 samplerate:48000 bitrate:448000
No accelerated IMDCT transform found
libdvdnav: demux error! 00 00 00 (should be 0x000001)

The strange characters are strange characters on my konsole, and there
is English language on the disc.

I tried to create image from dvdrw device with the same result.

TIA.
Tamas
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2.0.9 (GNU/Linux)
Comment: Using GnuPG with SUSE - http://enigmail.mozdev.org

iEYEARECAAYFAkl3gKUACgkQsuVyj8v2Zy7fAACcDa+7BXtAZBprh1O9oTynQyPx
ts8AoJj82CgEtYdAZ5S+oS/Ams4H26tp
=VA6D
-----END PGP SIGNATURE-----
--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse+help@xxxxxxxxxxxx

< Previous Next >
Follow Ups