Mailinglist Archive: opensuse (3613 mails)

< Previous Next >
Re: [opensuse] MySQL Plugins - Public Opinion
  • From: "Boyd Stephen Smith Jr." <bss@xxxxxxxxxxxxxxxxx>
  • Date: Wed, 21 Jan 2009 13:45:18 -0600
  • Message-id: <200901211345.18698.bss@xxxxxxxxxxxxxxxxx>
On Wednesday 21 January 2009, Michal Hrusecky <mhrusecky@xxxxxxx> wrote
about '[opensuse] MySQL Plugins - Public Opinion':
Packaging possibilities:

1) Make it as much modular as it is possible. Everything what can be
build as a module will be build as a module and let the people choose
what they really want.

I vote here. Specifically, introduce mysql-core and a mysql-$plugin for
each plugin. Have the mysql package bring in -core and all -${plugin}s
that are currently in 5.0. Have mysql-full bring in -core and
all -${plugin}s that are packaged, as long as no -$plugin conflicts with a
different one. Eventually, transition to the mysql package bringing
in -core and popular/expected plugins -- basically tuned toward "the
average user" instead of "exactly what 5.0 users expect".

(iii) All plugins are enabled by default if you are installing new
MySQL, enabled after upgrade from 5.0, keep untouched if upgrading
from 5.1

I vote here. Installing the plugin should be enough to enable it, and if
people want to disable plugins they have installed they can do it manually.
If a plugin has a history of security issues, then possibly change the
default for that specific plugin to disabled.
--
Boyd Stephen Smith Jr. ,= ,-_-. =.
bss@xxxxxxxxxxxxxxxxx ((_/)o o(\_))
ICQ: 514984 YM/AIM: DaTwinkDaddy `-'(. .)`-'
http://iguanasuicide.net/ \_/
< Previous Next >
References