Mailinglist Archive: opensuse (3536 mails)

< Previous Next >
Re: [opensuse] KDE4 desktop effects, ATI
  • From: "Jason Bailey, Sun Advocate Webmaster" <webmaster@xxxxxxxxx>
  • Date: Mon, 19 Jan 2009 22:24:14 -0700
  • Message-id: <49755FFE.1070402@xxxxxxxxx>
Jason Bailey, Sun Advocate Webmaster wrote:
Jason Bailey, Sun Advocate Webmaster wrote:
I'm trying to get desktop effects to work in KDE 4.1.3 (openSUSE 11.1
x86_64) and not having much luck. I'm curious if any of you have have
similar hardware and are having any luck.

I have it working on a laptop with a 256 MB nVidia card, and it runs
really slick. But in the desktop, I've got a DELL Optiplex GX620, which
came with an ATI Radeon X600 video card. I've not had good luck with ATI
on Linux...

openSUSE setup detected the card and installed drivers that are fairly
satisfactory for 2D. With the desktop effects in mind, I went to and downloaded the latest Linux x86_64 driver (i.e

Once the ATI driver had installed, I ran 'aticonfig --initial' as root
and rebooted.

I tried enabling KDE 4's desktop effects and got this:

Failed to activate desktop effects using the given configuration
options. Settings will be reverted to their previous values.

Check your X configuration. You may also consider changing advanced
options, especially changing the compositing type.

I've checked my /var/log/Xorg.0.log file, which doesn't show any sort of
error that I can see. The aticonfig command reports that there is a
'fglrx' section, and I can attest to that.

This is what I have in my xorg.conf file (among a few other things, of

Section "Device"
Identifier "Device[0]"
Driver "radeon"
VendorName "ATI"
BoardName "Radeon X600 (RV370) 5B62 (PCIE)"
Option "monitor-DVI-0" "Monitor[0]"

Section "Device"
Identifier "aticonfig-Device[0]-0"
Driver "fglrx"
BusID "PCI:1:0:0"

At this point I'm thinking that maybe my video card isn't supported, I
am missing some dependencies of some kind, or that my xorg.conf file
needs some tweaking.

Anyone willing to take a shot at this?

Okay, replying to my own post.

I took another look at the Xorg log file, realizing that using "tail"
right after I tried to enable effects wouldn't get me anywhere.

So, 'cat /var/log/Xorg.0.log | grep fglrx' gives me:

(==) fglrx(0): NoAccel = NO

(==) fglrx(0): NoDRI = NO

(II) Loading sub module "fglrxdrm"

(II) LoadModule: "fglrxdrm"

(II) Reloading /usr/lib64/xorg/modules/linux//

(==) fglrx(0): Capabilities: 0x00000000
(==) fglrx(0): CapabilitiesEx: 0x00000000
(==) fglrx(0): cpuFlags: 0x8000001d
(==) fglrx(0): OpenGL ClientDriverName: ""
(II) fglrx(0): [pcie] 262144 kB allocated
(II) fglrx(0): [drm] DRM buffer queue setup: nbufs = 100 bufsize = 65536
(==) fglrx(0): UseFastTLS=0
(==) fglrx(0): BlockSignalsOnLock=1
(II) fglrx(0): Direct rendering enabled
(II) fglrx(0): AC Adapter is used
(II) fglrx(0): Interrupt handler installed at IRQ 16.
(II) fglrx(0): Exposed events to the /proc interface
(II) fglrx(0): driver needs 1.4.x.y with x.y >= 99.906
(II) fglrx(0): detected
(II) fglrx(0): doing DRIScreenInit
(II) fglrx(0): DRIScreenInit for fglrx driver
(II) fglrx(0): [drm] DRM interface version 1.0
(II) fglrx(0): [drm] created "fglrx" driver at busid "PCI:1:0:0"
(II) fglrx(0): [drm] added 8192 byte SAREA at 0x2000
(II) fglrx(0): [drm] mapped SAREA 0x2000 to 0x7f6e21a26000
(II) fglrx(0): [drm] framebuffer handle = 0x3000
(II) fglrx(0): [drm] added 1 reserved context for kernel
(II) fglrx(0): DRIScreenInit done
(II) fglrx(0): Kernel Module Version Information:
(II) fglrx(0): Name: fglrx
(II) fglrx(0): Version: 8.56.4
(II) fglrx(0): Date: Dec 1 2008
(II) fglrx(0): Desc: ATI FireGL DRM kernel module
(II) fglrx(0): Kernel Module version matches driver.
(II) fglrx(0): Kernel Module Build Time Information:
(II) fglrx(0): Build-Kernel UTS_RELEASE:
(II) fglrx(0): Build-Kernel MODVERSIONS: yes
(II) fglrx(0): Build-Kernel __SMP__: yes
(II) fglrx(0): Build-Kernel PAGE_SIZE: 0x1000
(II) fglrx(0): [drm] register handle = 0x00004000
(II) fglrx(0): DRI initialization successfull!
(II) fglrx(0): FBADPhys: 0xc0000000 FBMappedSize: 0x00708000
(II) fglrx(0): FBMM initialized for area (0,0)-(1280,1440)
(II) fglrx(0): FBMM auto alloc for area (0,0)-(1280,1024) (front color
buffer - assumption)
(II) fglrx(0): Largest offscreen area available: 1280 x 416
(==) fglrx(0): Backing store disabled
(**) fglrx(0): DPMS enabled
(II) fglrx(0): Using XFree86 Acceleration Architecture (XAA)
(II) fglrx(0): Acceleration enabled
(WW) fglrx(0): Option "VendorName" is not used
(WW) fglrx(0): Option "ModelName" is not used
(II) fglrx(0): X context handle = 0x1
(II) fglrx(0): [DRI] installation complete
(==) fglrx(0): Silken mouse enabled
(==) fglrx(0): Using hardware cursor
(EE) AIGLX error: dlopen of /usr/lib/dri/ failed
(/usr/lib/dri/ wrong ELF class: ELFCLASS32)

That last line really got me thinking. I am running a 64-big version of
openSUSE. Is this driver trying to load a 32-bit version of DRI? If so,
is there a way around it?

Again replying to my own comment...

I verified my machine was loading the 32-bit version of I
removed the one from /usr/lib/dri/ and symlinked to the
copy in /usr/lib64/dri. Rebooted. Now the fglrx and glxinfo show opengl
as available, whereas before the commands didn't return anything but errors.

But I still cannot enable desktop effects in KDE 4. Strange. Any
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse+help@xxxxxxxxxxxx

< Previous Next >