Mailinglist Archive: opensuse (3536 mails)

< Previous Next >
Re: [opensuse] NFS idmapping daemon, autofs problem
  • From: "Jason Bailey, Sun Advocate Webmaster" <webmaster@xxxxxxxxx>
  • Date: Mon, 19 Jan 2009 18:31:38 -0700
  • Message-id: <4975297A.6060504@xxxxxxxxx>
james Wright wrote:
On 1/19/09, Jason Bailey, Sun Advocate Webmaster <webmaster@xxxxxxxxx> wrote:

I've not tried putting my NFS mount options in fstab because I've had
problems doing that before. I seem to recall that at the time that fstab
was processed before network services loaded, so the NFS mount could
never be discovered/found, and it would error out.

Autofs has worked very well for me and I'd like to keep using that.

When I do a directory listing on the remote NFS share, I don't get
"nobody" - I get numbers. But I can verify idmapd isn't starting.

Thoughts?


Did you create/edit /etc/auto.master? I doubt you would need to, but
you may also want to take a look at /etc/idmapd.conf.

- James W.

Yes, my /etc/imapd.conf and /etc/auto.master are set up correctly.

The thing is, the NFS mount is there... it works just fine.... except,
well, when I do a directory listing, I see things like this:

-rw-r--r-- 1 4294967294 4294967294 13944 2009-01-19 15:14 file1.jpg
-rw-r--r-- 1 4294967294 4294967294 17472 2009-01-19 17:13 file2.jpg
-rw-r--r-- 1 4294967294 4294967294 26589 2009-01-19 14:44 file3.jpg

Instead of "4294967294" I should be seeing the owning user and group,
like "joe" and "users" - you get the idea.

I know it's because idmapd isn't running. The problem is,
/etc/init.d/nfs won't load idmapd because I have no NFS mounts in
/etc/fstab, and I can't seem to invoke idmapd directly. This was not the
case with opensuse 11.0 or 10.3.

Thoughts?

Jason



--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse+help@xxxxxxxxxxxx

< Previous Next >