Mailinglist Archive: opensuse (3441 mails)

< Previous Next >
Re: [opensuse] compaq 6715b acpi problems and opensuse 11.1
  • From: Petri Asikainen <paca@xxxxxx>
  • Date: Sun, 18 Jan 2009 16:14:50 +0000
  • Message-id: <4973557A.2090404@xxxxxx>
Yes, I did update from 11.0.
I don't usually believe or do clean installs in linux world. but right
now I'm so desperate that I'll try that.
I have not my laptop right now, so I cannot check model version number
right now. Bios is updated to latest.

About bad acpi and bios: Take a look
/usr/src/linux/arch/x86/kernel/acpi/boot.c or
('s some irq-related work
arounds for 6715b and others.

Well, I have one spare-partition to test clean install, hope that helps.



JosipBroz wrote:
Hi, Petri!

It seems we're using exact same machines (64-bit x2 Turion 2 GHz, 160 GB HD,
GB RAM, ATI 1200, Broadcom 4321 wireless, AuthenTec fingerprint reader etc.)
and I can say HAL has improved from OS11.0. My 64-bit OS11.1 install is
working out-of-the-box, and the only thing I can report is I haven't
anything non-default. Meaning: no kernel compilation - just using the default
kernel, no proprietary ATI driver installed, no messing with the default
configuration, nothing at all out of the default - except for the wireless
which (of course) wouldn't work with the default SuSE open-source free
so I had to install the proprietary broadcom-wl from Packman. The problem may
be in your trying to update instead of making a clean install? I never needed
ANY kernel params on this machine, be it with OS11.0, OS11.1 or Mandriva
Moreover, it seems that now even the fingerprint sensor might finally work
(haven't tried it yet, though). I've never heard of the "bad BIOS and ACPI"
you're talking about. My machine is about 8 months old, so you possibly have
an older machine with an older BIOS revision?
I'd suggest you try and install OS11.1 from scratch on a spare partition if
you have one and see how that works.
One warning though: all the above goes for KDE3.x. If I log into KDE4.x, my
machine gets screwed in no time as well, so maybe that may be your problem?

Cheerz and good luck!

Dne sreda 14 januar 2009 ob 18:41:18 je Petri Asikainen napisal(a):
Hi list,
I'm having hard time after updated my 11.0 box to 11.1 (amd64).
(6715b and 6517b are known to have bad bios and acpi )
11.0 was running wuite well, I only needed edd=off boot parameter.

But with 11.1 and every kernel with it (I also tried newest from
I can run system only with "apm=off acpi=off irqpoll" and performance is
really bad.

If I boot with ony "irqpoll" parameter system boots and loads quite
nicely , even loads xorg put suddenly it goes down.

Could anyone help me to track/debug this problem?
Or is anyone running 11.1 with same hardware, if so what's your settings?


To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse+help@xxxxxxxxxxxx

< Previous Next >
Follow Ups