Mailinglist Archive: opensuse (3441 mails)

< Previous Next >
Re: [opensuse] No default gateway
  • From: Koenraad Lelong <k.lelong@xxxxxxxxxxxxxxxxxx>
  • Date: Wed, 14 Jan 2009 13:25:28 +0100
  • Message-id: <496DD9B8.9050905@xxxxxxxxxxxxxxxxxx>
medwinz schreef:
On Wed, Jan 14, 2009 at 5:06 PM, Stephen Holmes
<stephen@xxxxxxxxxxxxxxxxxx> wrote:
This happened to me when using NetworkManager. I switched back to the
standard ifconfig tools (yast2 lan) and disabled IPv6 and then switched
back to NetworkManager and it worked just fine.

Also, check the contents of your /etc/resolv.conf


seems like this bug, https://bugzilla.novell.com/show_bug.cgi?id=463015

I think something went wrong in /etc/resolv.conf and networkmanager

regards,
medwinz


Thanks for the replies.
There is a good resolv.conf.
I used ifup to have the network.
What I did :
-Disable ipV6 and reboot : no solution
-Enable Networkmanager : default gateway is OK, but a static route has disappeared (set by dhcp). That's the same problem I'm having on my 10.3 laptop.
-Enable traditional ifup : no default gateway, static route is OK.

From previous experiences I know ifup uses dhcpcd, and network manager uses dhcp-client, at least in 10.3.

--
Met vriendelijke groeten,
Koenraad Lelong
begin:vcard
fn:Koenraad Lelong
n:Lelong;Koenraad
org:ACE electronics
adr:;;IZ Webbekom 2118;Diest;VlaBra;3290;Belgie
email;internet:k.lelong@xxxxxxxxxxxxxxxxxx
title:R&D Manager
tel;work:+32 13 531906
tel;fax:+32 13 531908
x-mozilla-html:FALSE
url:www.ace-electronicss.be
version:2.1
end:vcard

< Previous Next >