Mailinglist Archive: opensuse (3513 mails)

< Previous Next >
Re: [opensuse] Re: Two 11.1 Installation Problems
  • From: dilogsys@xxxxxxxxxxxx
  • Date: Mon, 12 Jan 2009 10:40:14 +0200
  • Message-id: <ef5ba6bc105f3.496b1e0e@xxxxxxxxxxxx>
Hello folks!

The problem has been solved -sort of. Before I explain a few things here,
thanks to everyone who tried to help.

----------

What follows is written after considerable though - and I hope that someone out
there in Novell/openSUSE is paying attention.

----------

I noticed that there several other problems with the system as installed, not
the least of which, Firefox would not come up, insisting that there was an
unresponsive copy running. ps -ef showed nothing that I could identify.

Since my installation is a production system i.e. for real work, I decided to
go for a re-install under the following conditions:

1. I insist on my own partition setup.
2. I would choose a "standard" installation selection - KDE 4.1, and let it run
to completion without interference.
3. I will take all the defaults offered along the way, as far as possible.
4. I will do all private software selections and system tweaking after the
installation completes.

The results were fascinating in several ways:

1. The installation indeed completed successfully, with everything working as
expected.
2. The "path" taken by the process was quite different from that when I
predefined my software package choices in my first attempt. For one, the
process used "images" of some sort to plonk everything on the hard disk and
install from there; in that respect the installation went much faster than my
first attempt. Further, things were done in a different order - for example, it
did not try to validate my internet connection until after the first boot.
Another oddity was the date / time setup: In my second attempt it did not try
to connect me to the NTP server (which I don't need anyway) and mess up the
hardware clock (which it did on the first attempt).

3. Despite the relative smoothness of my second installation, there were still
a few disconcerting glitches: At least twice I was unexpectedly thrown back to
the package manager (once after the automatic updates) and once a bit later.
Now, to an old SUSE hand (from 6.1 if you please) that was fine; but it made me
start to wonder about usability issues, to which I will return below. The other
"glitch" (or perhaps a feature?) was that yast2 had a lot of things missing,
requiring additional manual installation. The prime example was the DHCP server
which is essential for using the box as a LAN server. I installed the DHCP
server, but I had to look for and separately install the SUSE module needed to
configure it. And while on this - where in 11.1 do you enable IP forwarding? In
10.3 there was a check box for it in the firewall setup. In 11.1 it's no longer
there or anywhere else. (In the end I used the system configuration module to
enable it, by hand.) Anyway, forewarned is fore-armed, and I'll be ready for
this when I get to configure Samba ...

4. Back to usability: What of the obvious question: What would a Newbie do in
such situations? Being unexpectedly thrown into an unfamiliar package manager
would be disconcerting, to put it mildly. And what of LAN configuration? The
Newbie answer is very simple: Go back to Win XP Pro where you can set up a
small LAN "out of the box", without ever knowing about DHCP and IP forwarding -
I know; I've done it.

Notwithstanding the fact that you get what you pay for, some of the usability
issues (a polite euphemism for "screw-ups") point to a much deeper problem.

First, all the beta testing in the world by volunteers, who are for most part
technical enthusiasts won't help. I find it hard enough myself, to enter into
the mentality of a "monkey with two left thumbs" - but that's the level of 80%
of the desktop market. If you don't agree, ask Microsoft! (What might help is
another (major) issue beyond the scope of this note, and probably off-topic for
this list.)

openSUSE (and presumably other Linux distributions) is just not for that
market. The attempt by Novell/openSUSE to make the 11.1 installation process
feel like an Win XP install - even to the extent of using bits of Microsoft
terminology - cannot succeed.

What all this tells me is that there is a certain ambivalence (a polite
euphemism for "lack of direction") in the Novell/openSUSE group about where
openSUSE should be going. I even wonder if Novell wouldn't mind if openSUSE got
quietly swallowed up by another Linux distributor or simply disappeared.

That is far more troubling than this or that installation glitch.

And I haven't even got around to assessing the 11.1 release from the point of
view of day-to-day use.

I think that the point is clear and enough said here.

Regards,

Daniel

P.S. For Rajko: The DVD was fine - it passed the media check test, and none of
the packages I used, were corrupt.

----- Original Message -----
From: "Rajko M." <rmatov101@xxxxxxxxxxx>
Date: Sunday, January 11, 2009 21:33
Subject: Re: [opensuse]  Re: Two 11.1 Installation Problems
To: opensuse@xxxxxxxxxxxx

On Sunday 11 January 2009 08:25:03 am Carlos E. R. wrote:
On Sunday, 2009-01-11 at 14:13 +0200, dilogsys@xxxxxxxxxxxx wrote:
Installed from a commercial third party DVD. (pctech101,
http://pctech101.com/)

Then maybe those people didn't create the DVD right.

I don't think they actually create anything.
It is just bad copy.

It should be updated, but from online repositories.

--
Regards, Rajko
--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse+help@xxxxxxxxxxxx

--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse+help@xxxxxxxxxxxx

< Previous Next >
Follow Ups