Mailinglist Archive: opensuse (3513 mails)

< Previous Next >
Re: [opensuse] Re: YaST fails to configure Hauppauge 350 PVR card]

Thanks again Charles for your reply, I will intersperse my results (comments) within your queries below...

Marc..


Charles Philip Chan wrote:
Marc Chamberlin <marc@xxxxxxxxxxxxxxxxxx> writes:

OK.... Thanks Charles for your reply... but... SOMETHING is wrong with YaST!

I guest someone messed up and forgot that it is part of the kernel
package now.

Anywise, I go through the process of configuring the PVR-350, and when
done YaST "seems" to be happy but next time I open YaST and look at
the TV cards, it is no longer configured...

There is really nothing to configure (it auto-configures itself these
days). As long as you have the modules and the firmware install, udev
will take care of the rest.

Also don't relay on YaST. My card doesn't show up there either.

Nor does MythTV find anything at /dev/video0 (or any where else when
it does a probe...) In previous SuSE 10.x releases I simply had to
configure the card with YaST and then MythTV would find it OK.. No
longer happening!

1. What is the output of

,----
| lsmod | grep ivtv
`
lsmod | grep ivtv
ivtv 134496 0
videodev 31236 3 msp3400,tuner,ivtv
compat_ioctl32 1104 1 ivtv
i2c_algo_bit 5764 1 ivtv
cx2341x 11076 1 ivtv
v4l2_common 10648 6 msp3400,saa7127,saa7115,tuner,ivtv,cx2341x
tveeprom 11248 1 ivtv
i2c_core 29972 13 tuner_simple,tda9887,tda8290,msp3400,saa7127,saa7115,tuner,ivtv,i2c_algo_bit,nvidia,v4l2_common,tveeprom,i2c_i801
Reading Mikes inputs I also looked at /dev and found

cd /dev
nova:/dev # ls vid*
video video0 video16 video24 video32 video48
nova:/dev # ll video*
lrwxrwxrwx 1 root root 6 2009-01-05 13:14 video -> video0
crw-rw---- 1 root video 81, 0 2009-01-05 13:14 video0
crw-rw---- 1 root video 81, 16 2009-01-05 13:14 video16
crw-rw---- 1 root video 81, 24 2009-01-05 13:14 video24
crw-rw---- 1 root video 81, 32 2009-01-05 13:14 video32
crw-rw---- 1 root video 81, 48 2009-01-05 13:14 video48
?
2. If you don't see any ivtv mouldes, what happens if you run

| modprobe ivtv
I didn't do this since it appears I do have the ivtv modules...

3. Did you run mythtv-setup?

Yes and that is when I noticed I am having troubles... In the Capture Card Setup section, I am selecting for Card type: MPEG-2 encoder card (PVR-x50, PVR-500) This fails to fill in anything in the field for Video device: So I guessed and tried to fill it in with /dev/video (also tried /dev/video0, /dev/video16, /dev/video24, /dev/video32, and /dev/video48 just for the heck of it... though I have no idea what these other video devices represent, I do not have a webcam or any other video sources on this particular system) All resulted the the Probed info" field saying "Failed to open" and with the Default input: field saying "Could not open '/dev/video_' to probe its inputs. So my guess/understanding of this is that mythtv-setup is failing to find the video device for the Hauppauge card...




--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse+help@xxxxxxxxxxxx

< Previous Next >