Mailinglist Archive: opensuse (3110 mails)

< Previous Next >
Re: [opensuse] openSUSE 11.1 - of grub,md/lvm root, and related headaches
  • From: Moby <moby@xxxxxxxxxxxxxx>
  • Date: Mon, 05 Jan 2009 13:03:21 -0600
  • Message-id: <49625979.2090506@xxxxxxxxxxxxxx>


Josef Reidinger wrote:
Moby wrote:
I have had a system running fine since oss 10.1 (upgraded from there on
to the current nightmare that is 11.1).

Here is the system disk layout:

Two 300 GB SATA hard drives - sda and sdba
sda1 and sdb1 are 130 MG, them mirrored using md raid into /dev/md0. /dev/md0 has ext3 mounted as /boot.
sda2 and sdb2 are 1 GB, then mirrored using md raid into /dev/md1. /dev/md1 is swap.
sda3 and sdb3 are 274 GB, then mirrored using md raid into /dev/md2. /dev/md2 has lvm on it, with / being /dev/system/system.
Grub installed in mbr of sda.

This system has been running great. I upgraded in-place from 11.0 to
11.1, and everything was still fine.
Then I built a custom kernel (as I have done with all other versions -
the only thing I change is set the processor type). During the custom
kernel install phase, make modules_install worked fine, but I noticed
some weird device-mapper "no such file or device" error message during
make install. I did not think much of it (probably a BIG mistake). Verified new vmlinuz and initrd were in place and /boot/grub/menu.lst
looked kosher. Rebooted the system, and it went to pot.


https://bugzilla.novell.com/show_bug.cgi?id=463451

JR
Thanks Josef, I had seen the issue mentioned in that bug and worked around it (there was a patch for Tools.pm in bootloader mentioned somewhere). However, having put a work around in place for this bug still does not do anything to help with the Grub issue.

--
--Moby

They that can give up essential liberty to obtain a little temporary safety
deserve neither liberty nor safety. -- Benjamin Franklin


--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse+help@xxxxxxxxxxxx

< Previous Next >
References