Mailinglist Archive: opensuse (2343 mails)

< Previous Next >
Re: [opensuse] cups does not print (11.1)
  • From: "Leen de Braal" <ldb@xxxxxxxx>
  • Date: Mon, 5 Jan 2009 16:06:11 +0100 (CET)
  • Message-id: <4422.192.168.0.66.1231167971.squirrel@xxxxxxxxxxxxx>

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1



On Monday, 2009-01-05 at 14:29 +0100, Leen de Braal wrote:

Try that. :-?

Well, if you read the next line, then I don't think I need more
debugging
info for now.

I read it, that's why I put that smiley. I would try, anyway... maybe it
says where it looks for libraries. Maybe there is a previous error.


Setting loglevel to debug gives me loads of data, hundreds of kilobytes. I
cut out the (what I think) is relevant, the lines around the E-lines
(errors):
==========
D [05/Jan/2009:14:47:15 +0100] cupsdProcessIPPRequest: 37 status_code=0
(successful-ok)
D [05/Jan/2009:14:47:15 +0100] PID 19520 (/usr/lib/cups/filter/pstops)
exited with no errors.
E [05/Jan/2009:14:47:15 +0100] PID 19523 (/usr/lib/cups/filter/CUPSToOmni)
stopped with status 1!
D [05/Jan/2009:14:47:15 +0100] [Job 5] Page = 612x792; 18,14 to 594,778
D [05/Jan/2009:14:47:15 +0100] [Job 5] slow_collate=0, slow_duplex=0,
slow_order=0
D [05/Jan/2009:14:47:15 +0100] [Job 5] Before copy_comments - %!PS-Adobe-3.0
D [05/Jan/2009:14:47:15 +0100] [Job 5] %!PS-Adobe-3.0
D [05/Jan/2009:14:47:15 +0100] [Job 5] %%BoundingBox: 0 0 612 792
D [05/Jan/2009:14:47:15 +0100] [Job 5] %%Pages: 1
D [05/Jan/2009:14:47:15 +0100] [Job 5] %%LanguageLevel: 1
D [05/Jan/2009:14:47:15 +0100] [Job 5] %%DocumentData: Clean7Bit
D [05/Jan/2009:14:47:15 +0100] [Job 5] %%DocumentSuppliedResources:
procset testprint/1.3
D [05/Jan/2009:14:47:15 +0100] [Job 5] %%DocumentNeededResources: font
Helvetica Helvetica-Bold Times-Roman
D [05/Jan/2009:14:47:15 +0100] [Job 5] %%Creator: Michael Sweet, Apple Inc.
D [05/Jan/2009:14:47:15 +0100] [Job 5] %%CreationDate: D:20070606214000+0500
D [05/Jan/2009:14:47:15 +0100] [Job 5] %%Title: Test Page
D [05/Jan/2009:14:47:15 +0100] [Job 5] %%EndComments
D [05/Jan/2009:14:47:15 +0100] [Job 5] Before copy_prolog - %%BeginProlog
D [05/Jan/2009:14:47:15 +0100] [Job 5] Before copy_setup - %%Page: 1 1
D [05/Jan/2009:14:47:15 +0100] [Job 5] Before page loop - %%Page: 1 1
D [05/Jan/2009:14:47:15 +0100] [Job 5] Copying page 1...
D [05/Jan/2009:14:47:15 +0100] [Job 5] pagew = 575.7, pagel = 763.1
D [05/Jan/2009:14:47:15 +0100] [Job 5] bboxx = 0, bboxy = 0, bboxw = 612,
bboxl= 792
D [05/Jan/2009:14:47:15 +0100] [Job 5] PageLeft = 18.1, PageRight = 593.9
D [05/Jan/2009:14:47:15 +0100] [Job 5] PageTop = 777.5, PageBottom = 14.5
D [05/Jan/2009:14:47:15 +0100] [Job 5] PageWidth = 612.0, PageLength = 792.0
D [05/Jan/2009:14:47:15 +0100] [Job 5] Wrote 1 pages...
D [05/Jan/2009:14:47:15 +0100] [Job 5] CUPSToOmni: Starting a print job.
D [05/Jan/2009:14:47:15 +0100] [Job 5] CUPSToOmni: Args = 6, "HPLJ2100",
"5", "anonymous", "Test Page", "1",
"job-uuid=urn:uuid:620573a7-8a16-36ae-5942-f90c79c647f7"
D [05/Jan/2009:14:47:15 +0100] [Job 5] CUPSToOmni: The library name is
"libHP_LaserJet_2100.so"
E [05/Jan/2009:14:47:15 +0100] [Job 5] CUPSToOmni: Fatal error: unable to
load "libHP_LaserJet_2100.so", g_module_error returns
"libHP_LaserJet_2100.so: cannot open shared object file: No such file or
directory"
E [05/Jan/2009:14:47:15 +0100] [Job 5] CUPSToOmni: No pages printed!
==============

I have also found bug 429345 in bugzilla, which is about the same problem
and seems unresolved.
I will ask questions there too.

Carlos, thanks for thinking with me.

But why can it not find the .so??? It is there, it is a
link:

I've no idea.

-

--
L. de Braal
BraHa Systems
NL - Terneuzen
T +31 115 649333
F +31 115 649444
--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse+help@xxxxxxxxxxxx

< Previous Next >
Follow Ups