Mailinglist Archive: opensuse (2483 mails)

< Previous Next >
Re: [opensuse] Digikam refuse to start
  • From: Martin /Nightowl/ Byttebier <nightowl@xxxxxxxxxx>
  • Date: Sun, 4 Jan 2009 01:09:50 +0100
  • Message-id: <20090104010950.6f7a2959.nightowl@xxxxxxxxxx>
On Sat, 3 Jan 2009 18:58:12 -0500 (EST)
"Robert P. J. Day" <rpjday@xxxxxxxxxxxxxx> wrote:

On Sun, 4 Jan 2009, Martin /Nightowl/ Byttebier wrote:

Hello,

I recently installed OpenSuse 11.1 and I just discovered Digikam
won't run at all.

When Digikam started from shell I get this:

digikam: error while loading shared libraries: libdigikam.so.0:
cannot open shared object file: No such file or directory

tos4ever@linux-u3sk:/opt/kde3/lib> ls -l |grep libdigikam.so.0
lrwxrwxrwx 1 root root 19 jan 4 00:33 libdigikam.so.0 ->
libdigikam.so.0.0.0 -rwxr-xr-x 1 root root 5052864 dec 3 14:58
libdigikam.so.0.0.0

I'm using digikam-0.9.4-51.18

What can I do to get Digikam working?

i notice that the digikam lib is in a non-standard place, no?
/opt/kde3/lib. are you sure that directory is in your library search
path?

Euch. I ran ldconf
And now Digikam works

cat /etc/ld.so.conf
/usr/X11R6/lib/Xaw3d
/usr/X11R6/lib
/usr/lib/Xaw3d
/usr/i386-suse-linux/lib
/usr/local/lib
/opt/kde3/lib
include /etc/ld.so.conf.d/*.conf

Thanks



--

UTSI: http://users.telenet.be/tos4ever/utsi.htm
Atari FTP-site: ftp://kurobox.serveftp.net:3021
--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse+help@xxxxxxxxxxxx

< Previous Next >