Mailinglist Archive: opensuse (2835 mails)

< Previous Next >
Re: [opensuse] 11.1 - k3b will not run for non-root, what was the trick?
  • From: Florian Gleixner <flo@xxxxxxxxx>
  • Date: Wed, 24 Dec 2008 15:45:48 +0100
  • Message-id: <49524B1C.5050609@xxxxxxxxx>
kanenas@xxxxxxxxxxxxx wrote:
On Wednesday 24 December 2008 01:17:15 am Florian Gleixner wrote:
David C. Rankin wrote:

11.1 w/KDE3 and k3b will not run for non-root. I have added the user to
cdrom group, still no joy. Works fine in 11.0, but not 11.1. I recall a
work-around that circulated about this a few months ago, but I didn't
write it down. Any one have it handy?
This was my problem once:

my system misses the "+" sign discussed on that page, k3b can not even see
drive(external, mounted on usb), but nerolinux has absolutely no problem with
k3b used to like too, a looong time ago.
has anyone tried the "old" cdrkit, before the wodim "fork"?

resmgr schould change the permissions of the cd/dvd writer device so
that you can write on it. resmgr does this if you login on your
graphical environment (kde, gnome, ...). resmgr sets acls on that device
(see "man setfacl" and "man getfacl"). resmgr fails, if your group has
no name. This often happens if you use ldap or simply if you upgrade or
move user accounts from one machine to another. Check this: type "id
-ng". If you see a number, you have to fix that. If you see a name, then
you may have hit another bug.
Do a "su" and then type: "resmgr dump" to see if resmgr gave you some
permissions. It should dump something like this:

grant "yourusername" cdrom

To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse+help@xxxxxxxxxxxx

< Previous Next >
Follow Ups