Mailinglist Archive: opensuse (1986 mails)

< Previous Next >
Re: [opensuse] Repos for 10.3 gone on mirrors and
  • From: "David C. Rankin" <drankinatty@xxxxxxxxxxxxxxxxxx>
  • Date: Fri, 21 Nov 2008 12:50:50 -0600
  • Message-id: <4927030A.2060902@xxxxxxxxxxxxxxxxxx>
LLLActive@xxxxxxx wrote:
Rodney Baker wrote:
On Tuesday 18 November 2008 19:25:07 LLLActive@xxxxxxx wrote:

Hi all,

could someone tell me what the following error message means when I try
to configure Online Update on an older OpenSUSE 10.3 that worked before:

Execute curl command failed with '7':
curl: (7) couldn't connect to host

When I try to add a repo e.g.:, it creates a link and says that it
could not connect to host. I can navigate to with firefox and see
all the patches. The mirrors like gwdg in Germany does not have 10.3

Do we have problems with the N├╝renberg/German sites again?




I was having problems with this on the weekend doing an update from 10.3 to
11.0 on a running system (which was successful, in the end...); the problem
was that curl was using my local squid proxy, but squid kept crashing due to
zypper having filled up /var with all of the downloaded rpm's. They were
already installed but the complete update process hadn't yet finished so
hadn't been removed. Took me ages to figure that one out. Once I ran "zypper
clean", then restarted squid with a /var partition that had some room again,
everything completed fine.

Thing is, I'm not sure where curl detects its proxy settings from. With
Firefox set to connect directly with no proxy I was also able to browse the
repositories online (which only served to confirm that the problem was
at my end...).



sudo "zypper clean"
root's password:
sudo: zypper clean: command not found

I see no "clean" switch for with zypper -h

I have "zypper-" and "Linux Server1 #1 SMP 2008-10-14 22:17:43 +0200 x86_64 x86_64
x86_64 GNU/Linux"

I deleted all the repos with yast, but cannot add them any more, not
even the "community repos"



There seems to be an atavistic problem with the update repository that
probably transient. This morning I got this:

11:17 providence~> sudo zypper in opera
Refreshing Main Update Repository
Repository Main Update Repository is invalid.
File ./repodata/patch-OpenOffice_org-5738.xml not found on media:
Please, check if the URLs defined for this repository are pointing to a valid
Disabling repository Main Update Repository because of the above error.

11:17 is CST time or 17:17 zulu. I then tried again a few minutes ago
and all
is fine:

12:41 providence~> sudo zypper ref
Refreshing ''
* Building repository '' cache
Refreshing 'Main Update Repository'
* Cleaning repository 'Main Update Repository' cache
* Building repository 'Main Update Repository' cache
Repository 'openSUSE BuildService - X11:XGL' is up to date.
All repositories have been refreshed.

So whatever problem there was at 11:17 was gone by 12:41.

David C. Rankin, J.D.,P.E. |
Rankin Law Firm, PLLC | Countdown for openSuSE 11.1
510 Ochiltree Street |
Nacogdoches, Texas 75961 |
Telephone: (936) 715-9333 | openSoftware und SystemEntwicklung
Facsimile: (936) 715-9339 | |
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse+help@xxxxxxxxxxxx

< Previous Next >