Mailinglist Archive: opensuse (1986 mails)

< Previous Next >
Re: [opensuse] Attempting (and failing) to use my UPS
  • From: "Carlos E. R." <robin.listas@xxxxxxxxxxxxxx>
  • Date: Wed, 19 Nov 2008 04:08:58 +0100 (CET)
  • Message-id: <alpine.LSU.2.00.0811190355480.6163@xxxxxxxxxxxxxxxx>
Hash: SHA1

On Tuesday, 2008-11-18 at 21:09 -0500, Patrick Shanahan wrote:

* Carlos E. R. <robin.listas@xxxxxxxxxxxxxx> [11-18-08 20:19]:

I have tried "RUN_AS_USER root" in upsmon.conf to no avail. If I use:

I have (in upsmon.conf)
MONITOR myups@localhost 1 upsd password master


in upsd.users


password = 123456
allowfrom = localhost
upsmon master

currently. I commented out some entries. Till the driver runs, that part is secondary.

# "BELKIN Active Battery Backup"
driver = megatec_usb
port = auto
desc = "Local UPS"
user = root

I don't believe the "user =" line is allowed here. Oops, man ups.conf
allows it as optional. But you have to define them in upsd.users.


but the driver complains it does not recognise the "user" option.
Currently I have this startup line:

$UPSDRVCTL_BIN -u root start || rc_failed

for you looks like $UPSDRVCTL_BIN =

No, I have a line before that:

echo "User: "$UPSD_USER " Owner: " $UPS_OWNER " Port: " $PORT " Driver
controller: "$UPSDRVCTL_BIN

that prints me the vars, and they are:

nimrodel:~ # time rcupsd start
User: upsd Owner: upsd:root Port: auto Driver:

The driver controller runs as root, I think. The daemon runs as "upsd", but the driver itself is doubtfull. i think it runs as upsd too..

for me:
$UPSDRVCTL_BIN = /usr/lib/ups/driver/newhidups

ps aux | grep ups
/usr/lib/ups/driver/newhidups -a myups

Thats the driver, not the controller. They are two processes.

have you tried looking at the output of:

That would be

/usr/lib/ups/driver/upsdrvctl -a myupsd -DDDD

which fails to run. It would be the one I posted on my previous email,

/usr/lib/ups/driver/megatec_usb -DDDD -a myups

which does indeed work. But started from the controller, as the script does, it fails.

there is a lot of information there

Yes, I saw it. But nothing that helps starting the daemon: the daemon runs as user, and thus is denied access to the USB.

- -- Cheers,
Carlos E. R.

Version: GnuPG v2.0.9 (GNU/Linux)

To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse+help@xxxxxxxxxxxx

< Previous Next >
Follow Ups