Mailinglist Archive: opensuse (3625 mails)

< Previous Next >
Re: [opensuse] shutdown hangs after kernel update -- ADDENDUM
  • From: Daniel Bauer <linux@xxxxxxxxxxxxxxxx>
  • Date: Wed, 25 Jun 2008 10:14:12 +0200
  • Message-id: <200806251014.13679.linux@xxxxxxxxxxxxxxxx>
On Wednesday 25 June 2008 08:06:45, Basil Chupin wrote:
Moby wrote:
Basil Chupin wrote:
Basil Chupin wrote:
Daniel Bauer wrote:
On Tuesday 24 June 2008 06:59:15, Basil Chupin wrote:

To Daniel: I've been having this problem - of 'shutdown' hanging -
ever since I installed 10.3, and irrespective of which kernel YaST
upgraded the kernel to. If the OS shutdown properly without any
convolutions I considered that something had gone wrong :-) and
to accept it gracefully :-) .

This doesn't happen anymore now with 11.0 installed.

Yes, I use 10.3. Before the update to the problem
never occured, neither on my PC nor on my laptop.

Well, I jinxed myself by replying to you and telling you that in 11.0
I've never had the system not shutdown properly.

Last night the shutdown locked up solid :-( . First the screen went
to init 3 and gave me the login prompt (just like with 10.3) and
after I issued the 'halt' command everything just locked up. Only way
out of this was to press and hold the power-on button.

The first thing I did when powering up a short time ago this morning
was to do e2fsck on the partition the OS is installed; the error
found was that the superblock was last accessed in the future! - same
(at least most of the time) as in 10.3.

The interesting thing is that last night there was one upgrade put
through by zypper, I think it was security related, and that upgrade
was TIMEZONE 2008c-0.1. Whether this is the cause I don't know but
I'll see if the OS hangs again tonight when I try to shut it down.


Here it began with the update to kernel

I have been experiencing system freezes on one my systems that was
rock solid with 10.3 but now intermittently freezes with 11.0.
Problem appears to occur only when running Gnome. I thought I had the
problem licked by removing powersaved, but that was a premature

I don't run Gnome (and never have).

I run KDE.

In another thread (?in this list or opensuse-factory, cannot remember
:-( ) there is mention of what appears to be a bug in the kernel which
is associated with reiserfs -- but please look yourself to make sure for
yourself what I state is correct.

However, I do not use reiserfs so for me the problem would appear to lie

I filed a bug here:

To avoid data loss I now logout as user from KDE, go to a text console (from
the login menu) an umount all but the system directory.

However, yesterday I could not umount /home, it said it was in use. But I
don't know why. I had nothing left running and I was logged out as user, so
there should be no access needed to /home anymore.

It's really weard. And of course I cannot umount the system directory. I had
no data loss until now (I hope it stays that way!) but reiserfs always has a
lot of journal-things to do when staring up...

This friday I would have an appointment with an internet-café here in
Barcelona that I tried to convince to use Linux because of all their problems
always occuring with Windows. But if I go there now I'd get a read head,
because their windows seems to be more stable than my linux (with the WLAN
problems and the shutdown freeze), and he can proudly click on "start" to
show me how a system can be shutdown...

This is not just a rant. It would really have been a chance, but with a
laptop "working" like mine, I simply have to cancel the appointment.

Daniel Bauer photographer Basel Barcelona
professional photography:
erotic art photos:
Madagascar special:
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse+help@xxxxxxxxxxxx

< Previous Next >
Follow Ups