Mailinglist Archive: opensuse (3412 mails)

< Previous Next >
[opensuse] Opensuse 10.3 installation on UMPC - Kernel panic - not syncing: Attempted to kill init!
  • From: Nickolai <kolyanoid@xxxxxxxxxxx>
  • Date: Tue, 22 Jan 2008 13:54:07 +0300
  • Message-id: <200801221354.08059.kolyanoid@xxxxxxxxxxx>
Hello, everyone!

A few weeks ago I bought a UMPC - Raon Everun.

My model specs are:
CPU AMD Geode LX900. L1 64KB-1/64KB-D L2 128KB
CPU Speed 600MHz
System Memory 512MB SO-DIMM DDR400 (PC3200) 1x Slot
Hard Drive + Storage Internal 6GB SSD (Solid State Disk) + Toshiba 1.8" 60GB
VGA Chipset High performance 2D graphics controller. Intel MMX + AMD 3Dnow
VGA Resolution 800x480 Native resolution with Zoom & Panorama : VGA up to
1680 x 1050 resolution
Display 4.8" Touch screen TFT LCD Resistive Touch, 16.7M Color, 280cd / m2,
300:1 contrast ratio, Auto-Rotation / Auto-Brightness control

I am trying to run linux on this device, but have no luck installing it :(
I am using external USB DVD-RW drive to boot from. Just after "Loading linux
kernel" progress bar reaches 100% and the initial boot screen appears, the
kernel crashes (Kernel panic - not syncing: Attempted to kill init!). For
more details look below.
I have tried following booting options:
1) OpenSUSE 10.3 (normal settings)
2) OpenSUSE 10.3 (safe settings)
3) OpenSUSE 10.3 (text mode + safe settings + acpi=off + noapic)
4) OpenSUSE 10.3 (rescue system)
5) OpenSUSE 10.3 (firmware test)
6) OpenSUSE 10.2 (normal settings)
7) OpenSUSE 10.3 LIVE-CD (KDE)

And everywhere I get the kernel crash (but only memory test from OPENSUSE CD
seems to work fine).
Yet, this problem seems to only in OpenSUSE's linux kernel, since I've tried
other linux distributions and most of them worked fine.
But no linux distribution succeded in getting on-board mouse and keyboard
working, that is why I can only tell you about booting (since have no input).
1) Knoppix 3.7 Live-CD (yes, that's old one, I know :) ). Booted perfectly to
the end (KDE desktop)
2) Back Track 2.0. Booted perfectly to command line (that is OK, since in back
track KDE starts MANUALY, and i have no input to continue)
3) Mandriva 2008. Booted perfectly and started installation app.
4) Kubuntu 7.10. Booted, but hanged just after starting X11

Guys, I REALLY need help here!!! :( I've got tired of crappy software on this
device! I NEED OPENSUSE! Not other distributions! I've got addicted to it! :)

Here is advanced info about the kernel crash, I hope it will help!


*pde = 00000000
Oops: 0000 [#1]
last sysfs file:
modules linked in:
CPU: 0
EIP: 0060:[<c01a9bd7>] Not tainted VLI
EFLAGS: 00010246 ( #1)
EIP is at sysfs_lookup+0x37/0x1e2
eax: 79c37938 ebx: d7cc0d74 ecx: d7d70634 edx 00000020
esi: 79c37938 edi: d7cc0dd4 ebp: d7d70634 esp d710bc50
ds: 007b es: 007b fs: 00d8 gs: 0000 ss: 0068
Process swapper (pid: 1, ti=d710a000 task=d7f8eab0 task.ti=d710a000)

Stack: d4e18b84 c017eb60 d7cc0dd4 d710bc7c d7f61ee0 c0175cbb c02d6d10 d7cc0d74
d4e18b84 d7f5c868 c01775b2 00299a31 00000003 d7ccfaa4 d7ccfaa4
d7ccfaa8 d710bcc4 c01a96d1 c130f020 d7f9231c d4e18b84 d7ccfaa0

Call Trace:
[<c017eb60>] d_alloc+0x14b/0x17e
[<c0175cbb>] cached_lookup+0x1e/0x66
[<c01775b2>] lookup_one_len+0xb3/0xd3
[<c01a96d1>] create_dir+0x37/0x18d
[<c01a9870>] sysfs_create_dir+0x49/0x63
[<c01cd404>] kobject_shadow_add+0xe1/0x188
[<c01cd554>] kobject_register+0x19/0x30
[<c01cd6a7>] kobject_kset_add dir+0x46/0x75
[<c023d7e4>] device_create+0x77/0x97
[<c02247d5>] tty_reister_device+0xb5/0xbd
[<c0239477>] serial8250_pm+0x0/0xb2
[<c0236df8>] uart_change_pm+0x20/0x28
[<c02381b1>] uart_add_one_port+0x21e/0x25c
[<c01c0038>] hmac_update+0x3d/0x5b
[<c01cd110>] kobject_release+0x0/0x8
[<c01cdcb8>] kref_put+0x60/0x6d
[<c023cf6e>] device_del0x200/0x222
[<c0236f1d>] uart_remove_on_port+0xc5/0xcf
[<c023adb1>] serial8250_register_port+0xf3/0x113
[<c023ba79>] serial_pnp_probe+0xfa/0x117
[<c021c0ad>] pnp_device_probe+0x63/0x82
[<c023ec4f>] driver_probe_device+0xc8/0x14b
[<c023edbb>] __driver_attach+0x52/0x87
[<c023e248>] bus_for_each_dev+0x30/0x51
[<c023eacc>] driver_attach+0x16/0x18
[<c023ed69>] __driver_attach+0x0/0x87
[<c023e4e8>] bus_add_driver+0x6d/0x17d
[<c038e4de>] kernel_init+0x14a/0x2be
[<c0104d46>] ret_from_fork+0x6/0x20
[<c038e394>] kernel_init+0x0/0x2be
[<c038e394>] kernel_init+0x0/0x2be
[<c0106117>] kernel_thread_helper+0x7/0x10

Code: 8b 40 54 8b 68 0c 83 c0 0c 89 44 24 10 83 ed 04 e9 a1 01 00 00 f6 45 18
0f 84 91 01 00 00 89 e8 e8 27 e7 ff ff 8b 7b 24 89 c6 <ac> ae 75 08 84 c0 75
31 c0 eb 04 19 c0 0c 01 85 c0 0f 85 6d
EIP: [<c01a9bd7>] sysfs_lookup+0x37/0x1e2 SS;ESP 0068:d7ed5c50
Kernel panic - not syncing: Attempted to kill init!
Clocksource tsc unstable (delta = 680110980 ns)
Time: pit clocksource has been installed/


This is all I could see on my screen.

Looking forward for help!! :)

This links may help to get the whole picture of aspects of running linux on
this device

Sorry for my English... :-[
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse+help@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages