Mailinglist Archive: opensuse (2086 mails)

< Previous Next >
Re: [opensuse] 10.3 Beta 2 - Yast installer issues?
  • From: Richard Creighton <rccj@xxxxxxxxxxx>
  • Date: Sat, 18 Aug 2007 18:10:56 -0400
  • Message-id: <46C76E70.4060707@xxxxxxxxxxx>
If  you are still able, you need to log into bugzilla and file a report
so the guys there can fix it.   I doubt they read this user  forum buty
they    pay serious attention to the bug reports filed.

http://bugzilla.novell.com

This sounds like one of their fixes had a major undesirable side effect
and they probably didn't know about it or they wouldn't have released it
as an update.

Richard


Rajko M. wrote:
> On Saturday 18 August 2007 04:14:46 pm John Layt wrote:
>   
>> A bit of testing confirms that I'm right, Yast is
>> deleting the installed files first.  For example, I
>> just tried to upgrade a few rpms, including libbz2.
>> So the installer deletes libbz2, then tries to install
>> the new rpm, but fails because libbz2.so.1 is missing
>> so it can't unpack it.  Ouch!
>>
>> Also, the full error message when the delete fails
>> makes it clear that it is an rpm error from trying to
>> remove the actual package files.
>>
>> John.
>>     
>
> Same here, during libzypp update.
> YaST suddenly exits. 
> Ouch2.
> YaST Control Center starts, but there was no modules. 
>
> Manual recovery with rpm worked. 
>
> Reproduced your test with libbz2.
>
> Now let me see how to recover from this.
>
>   
-- 
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse+help@xxxxxxxxxxxx

< Previous Next >
Follow Ups
References