Mailinglist Archive: opensuse (1809 mails)

< Previous Next >
Re: [opensuse] Followup: 10.2 SAX/8600GT/nVidia Binary Driver Strange Problem
  • From: Roger Oberholtzer <roger@xxxxxx>
  • Date: Fri, 10 Aug 2007 08:35:11 +0200
  • Message-id: <1186727711.16099.9.camel@xxxxxxxxxxxx>
On Fri, 2007-08-10 at 05:55 +0300, Andrei Verovski (aka MacGuru) wrote:
> Hi,
> 
> I have previously posted this message describing problem with 8600GT and 
> nVidia binary driver 100.14.03. Below I have included lspci and log 
> information, which might be necessary to track down the problem.
> 
> > I have just assembled new PC with Intel Core2 Duo, Gigabyte m/b,
> > Intel P35 Chipset, and Asus 8600GT/512MB PCIe video card.
> >
> > Software: SuSE 10.2 with latest kernel update, latest nvidia driver
> > from its web site installed manually ("modprobe nvidia" works)
> >
> > However, neither "sax2" neither  "sax2 -r -m 0=nvidia" do not work as
> > expected - sax2 ALWAYS switch to framebuffer mode.
> >
> > I have replaced video card with MSI 8600GT, installed it into another
> > PCIe slot, problem still exists.
> >
> > Strange enogh, since lspci DOES lists this video card. Additionally,
> > Windoze works on this PC, so it is not a hadware problem.
> 
> --------------------------------------------
> 
> lspci:
> 01:00.0 VGA compatible controller: nVidia Corporation Unknown device 0402 (rev 
> a1)
> 03:00.0 SATA controller: JMicron Technologies, Inc. JMicron 20360/20363 AHCI 
> Controller (rev 02)
> 
> --------------------------------------------
> 
> sax2 -p (seems like problem with detection)
> SaX: root Chip: 0 is -> VESA Framebuffer Graphics 01:00:0 0x10de 0x0402 AGP 
> fbdev

Sax knows nothing about the nvidia binary driver. It will not detect
cards that are detected by that driver and not the stock X.org drivers.
In fact, it will do just what you report. You must ignore Sax for this.
The most you can do is run the sax command nvidia suggest as part of a
SUSE install. Note that this command directly sets the name of the
driver to the nvidia binary. It does not do any sort of a probe.

So, is your problem really that sax reports that the device is a VESA
framebuffer device instead of an nvidia device? If so, then
check /var/log/Xorg.?.log to see what X ultimately decides. It seems
that you have nvidia set as the driver in xorg.conf. That should do it.
The stock X.org driver is called nv.

> 
> --------------------------------------------
> 
> nvidia-installer log file '/var/log/nvidia-installer.log'
> 
> creation time: Thu Aug 9 21:53:12 2007
> ------------ end of file:
> -> Installing 'NVIDIA Accelerated Graphics Driver for Linux-x86' (100.14.11):
> executing: '/sbin/ldconfig'...
> executing: '/sbin/depmod -aq'...
> -> done.
> -> Driver file installation is complete.
> -> Running post-install sanity check:
> -> done.
> -> Post-install sanity check passed.
> -> Shared memory test passed.
> -> Running runtime sanity check:
> -> done.
> -> Runtime sanity check passed.
> 
> sax2 -r -m 0=nvidia log:
> 09-Aug 22:02:10 <I> [ Sysp: XStuff detection data
> Card0 => DDC : <undefined>
> Card0 => Name : Monitor
> Card0 => Vendor : Generic
> Card0 => Primary : 01-00-0
> Card0 => Chipset : <undefined>
> Card0 => Vsync : 61
> Card0 => Hsync : 63
> Card0 => Vesa : 1280 1024 62 60
> Card0 => FbTiming : "1280x1024" 102.62 1280 1312 1472 1632 1024 1028 1032 
> 1048 -HSync -VSync
> Card0 => Dacspeed : 220
> Card0 => Modeline : <undefined>
> Card0 => Memory : 4096
> Card0 => Current : 01-00-0
> Card0 => RawDef : None
> Card0 => Option : None
> Card0 => Extension : None
> Card0 => Module : nvidia
> Card0 => Display : CRT
> Card0 => VesaBios : 3.0
> 
> 09-Aug 22:02:11 <I> [ Sysp: 3D detection data
> Card3D0 => Install : <none>
> Card3D0 => Remove : <none>
> Card3D0 => Packages : <none>
> Card3D0 => Active : 1
> Card3D0 => Answer : no
> Card3D0 => ScriptReal : <none>
> Card3D0 => ScriptSoft : <none>
> Card3D0 => Flag : <none>
> ]
> 09-Aug 22:02:12 <X> Startup...
> 09-Aug 22:02:12 <X> Startup on new Server: <:0.0>
> 09-Aug 22:02:12 <X> Logging File contents: /tmp/sax2-4257/xorg.conf [
> 
> Section "Device"
> BoardName "Framebuffer Graphics"
> BusID "1:0:0"
> Driver "nvidia"
> Identifier "Device[0]"
> VendorName "VESA"
> EndSection
> 
-- 
Roger Oberholtzer

OPQ Systems / Ramböll RST

Ramböll Sverige AB
Kapellgränd 7
P.O. Box 4205
SE-102 65 Stockholm, Sweden

Tel: Int +46 8-615 60 20
Fax: Int +46 8-31 42 23

-- 
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse+help@xxxxxxxxxxxx

< Previous Next >