Mailinglist Archive: opensuse (3175 mails)

< Previous Next >
Re: [opensuse] Oh my god, zypper is such a crap!
  • From: Pascal Bleser <pascal.bleser@xxxxxxxxx>
  • Date: Sat, 07 Apr 2007 17:12:12 +0200
  • Message-id: <4617B4CC.2020500@xxxxxxxxx>
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Jan Tiggy wrote:
> Anders Johansson schrieb:
>> No it didn't. YaST was based on libzypp in 10.1 too
> Sure it used libzypp too, but not only. And Yes I got here still 10.1
> running and that w/o libzypp installed. The Yast's packet management works!!

Hardly. YaST2's package management uses zypp. Period.
On 10.2 there are two options to use zypp:
1) either through ZMD (the "ZMD backend") then back to zypp and then to RPM
2) or directly to RPM (the "opensuse backend")

The option with the least issues is definitely the latter.

>> Yes, YaST uses libzypp as package management backend now. Do you have problems 
>> with libzypp? Do you notice things that don't work? So far I haven't seen 
>> many bugreports about libzypp not working.
> 
> Yes I have problems with libzyyp. I don't like things forced on me w/o
> giving me any alternatives!!

You have lots of alternatives:
- - yast->zypp->ZMD (eww) + rug
- - yast->zypp (better) + zypper (work in progress)
- - smart
- - yum
- - apt (RPM port) (not biarch capable)

>> And please don't try to make silly jokes about this, because rug/zmd don't use 
>> libzypp for their updates.
> 
> ...anymore! However it did use libzypp in 10.1.
> Now when couple of users got pissed off by the brain dead 'Ximians',
> Novel replaced rug with zypper.

No. Many, many people in the community (including me) have bugged the
SUSE engineers again and again to have ZMD removed.
In 10.3 the default yast2 package management will be zypp without ZMD
instead of zypp with ZMD, at last.

ZMD was pushed in by management decision, not by technical superiority.

> Well but that's not the point. I don't like libzypp and I don't trust
> Novell. Believe me or not, all my friends share this Point of View.

Gosh, is it paranoid time again.. ?
If you don't like zypp, then just don't use it (except for the
installation, where you have to) and stick with smart (or yum or apt or
whatever).

> As by now we still stick to SUSE just out of sentiment to the old times
> when SUSE was ours (German). Those days we knew what to expect from

The engineers working on the distribution are still sitting in N├╝rnberg.

> SUSE-Devs but now not anymore. I will wait for the 10.3 release and then
> decide whether I switch to another Distro or stick to 'Novell's SUSE'
> bit longer.
> Nevertheless, I respect your poit of view, but please respect mine too.
> I don't want libzypp and it is my right not to.

Sure, but why all that noise and not just use smart (or ...).

- --
  -o) Pascal Bleser     http://linux01.gwdg.de/~pbleser/
  /\\ <pascal.bleser@xxxxxxxxx>       <guru@xxxxxxxxxxx>
 _\_v The more things change, the more they stay insane.
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.5 (GNU/Linux)

iD8DBQFGF7TMr3NMWliFcXcRAs4gAJ9DmGJd5JekXKFikzjrY3EeyxzXWQCfXzFW
bzZ39jH3BQxsQRMUktt1v74=
=3oa7
-----END PGP SIGNATURE-----
-- 
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse+help@xxxxxxxxxxxx

< Previous Next >
Follow Ups