Mailinglist Archive: opensuse (4570 mails)

< Previous Next >
Re: [SLE] Menu font for Firefox almost fixed
  • From: Felix Miata <mrmazda@xxxxxx>
  • Date: Thu, 24 Nov 2005 11:19:34 +0000 (UTC)
  • Message-id: <4385A097.2BB8@xxxxxx>
[After reading your reply, I tried to investigate 9.2 further according
to your experience, but my 9.2 box, which is also my 9.3 box and an OS/2
& DOS box, has just decided not to POST any more. Feels like the
keyboard cable plug has become partially detached. Don't know when or if
I might be able to fix it, so my SuSEs might be limited to 9.0 & 10.0
for a while.]

B. Stia wrote:

> On Tuesday 22 November 2005 10:07 pm, Felix Miata wrote:

> Although I have GTK1 (gnomecc) installed I don't think any of my present
> apps use it. Probably should uninstall it and see what happens. Now, I
> looked in GTK2 (gnome-control-center) very carefully. I find a way to
> set the screen resolution but nothing for the dpi. I am supposing from
> some past email exchanges that X is supposed to know ??

Plain as day in all the screenshots at
http://members.ij.net/mrmazda/tmp/ff-gtk2-dpi.html in the
gnome-control-center Font Rendering Details window. DPI is short for
dots per inch resolution.

> If everything in chkcinfig --list is off does that mean that gnomecc is
> not doing anything? ( a conclusion from an earlier statement)

If everything in chkconfig --list was off you would have little if
anything working anywhere. Do you mean everything on the xfs line is
off? If so, turn it on for at least runlevel 5.

> > You can see in https://bugzilla.mozilla.org/show_bug.cgi?id=267194
> > that Akkana & I had more recent discussion, just over one year ago.
> > It seems I've learned enough since then that I need to update that
> > page again.

> OK, read that with interest. Supposedly everything was fixed. Didn't
> know you were a developer. Thanks

Developer in the usual sense of the word really isn't the right term for
what I do. I'm not a c++, gcc, java, JS, perl, python, bash, etc.
programmer. I do put in considerable time on the Mozilla project, but as
alpha tester, QA, bug reporter, website maintenance, user support, and
rarely, bug fixer. The only few bugs I've provided patch fixes for are
data or UI style (CSS) bugs. I keep Chatzilla open most of the time on
more than 12 channels, including irc://moznet/#css and
irc://moznet/#linux where anyone from here is welcome to join.

> OK, and I thank you. Here is what I found. I dropped back to level 3 and
> tried, several times. to enter the dpi parameter for startx. It choked
> and brought me back to the logon screen.

'startx -dpi 100' ? It worked for me with all #s I tried, e.g. 100, 120,
96, 108.

The thing to do then is to compare /var/log/XFree86.0.logs between
trying with and without a -dpi parameter to startx, and with starting
with xdm. There should be some difference(s) that would point someplace
useful.

> I then just did a plain startx
> in frustration and lo & behold it started with the 96 dpi resolution.
> What a wonderful difference. ( I had tried this earlier as to your
> suggestion but it didn't work. Probably because I had not yet edited
> the Xresources file)

Here's why I wanted to fiddle with 9.2 some more. It seems I forgot
there are two Xresources files:

/etc/X11/xdm/Xresources
/etc/X11/Xresources

So, I'd start by trying matching Xft.dpi: values at the end of each
file. On my Mandriva 2006 server, my only Linux box running and
available ATM, I have done exactly this, where each of the two came with
initial values set to 90, and where the within preceding comment says
"...prevents tiny fonts or huge fonts depending on the screen size".

> After doing that xdpyinfo reported screen resolution as 1600x1200 (no
> change) screen size as 432x321 ( as opposed to it's former 542x406 mm)
> and dpi as 94x95 (as opposed to it's former 75x75) Progress here. This
> is what it is supposed to be.

:-)

> Now, here is where I am at. If I start the OS with the graphical init 5
> I get the wrong paarameters. If I start at init 3 and do a startx it
> starts x with the proper parameters. I repeated this drill 3 or 4 times
> to verify the behavior.

> WHAT ?? is causing this ??

Linux configurabilty cuts two ways. :-p

If matching Xresources files don't fix it, next thing to try is the
other thing I wanted to start 9.2 for. In Mandriva in /etc/kde/kdm/kdmrc
for several versions there has been a default setting 'UseTheme=true'. I
know SuSE has been doing this in kdmrc too, but don't remember when it
started, which I'm pretty sure was sometime after 9.0. I don't like the
login manager behavior of these themes, so I change mine always to false
to get a traditional KDM greeter. It could be that there is a theme
conflict that doing as I have done would fix.

A peek into /etc/X11/Xsession shows references also to .Xresources and
.Xdefaults in $HOME. I'd check to see if those files exist, and if so,
see if there are any settings applicable to DPI in either or both. I'd
also look in /etc/X11/Xservers for a -dpi # parameter for :0, and if
there isn't one, try one.

If none of the above help, you could just keep doing startx, or proceed
to upgrade to 10.0. :-)
--
"I can do all things through Him who gives me strength."
Philippians 4:13 NIV

Team OS/2 ** Reg. Linux User #211409

Felix Miata *** http://members.ij.net/mrmazda/auth/


< Previous Next >
Follow Ups