Mailinglist Archive: opensuse (2441 mails)

< Previous Next >
Re: [SLE] [SOLVED] Re: partition copy
  • From: Mike McMullin <mwmcmlln@xxxxxxxx>
  • Date: Thu, 16 Jun 2005 08:39:57 -0400
  • Message-id: <1118925596.6466.20.camel@xxxxxxxxxxxxxx>
On Tue, 2005-06-14 at 16:14, Sunny wrote:
> OK,
> here is the summary:
> So, the solution was, as per Silviu Marin-Caea's and Mike McMullin's
> advice, I tried partimage. I did not used a server part for this. Just
> mounted the samba share, instructed partimage to create 2GB chunks,
> and of course to gzip the backup.
> After the partition backup, i did:
> dd if=/dev/hda of=mbr.img bs=512 count=1
> to backup the MBR.
> Then inserted the new HDD, and restored the MBR with
> dd if=mbr.img of=/dev/hda bs=512 count=1
> This as well restores the partition table.
> Now, the problem was that partimage failed to restore. It segfaulted
> using the user interface, and using the command line complained that
> the target partition is 0 size and can not continue. I rebooted the
> machine, and now everything worked fine. I would really like to know
> what I needed to do in order to refresh the partition table without
> rebooting, but I couldn't find any info about this.

I've never had this problem Sunny. My only problem has been with the
MBR though, and I fixed it (WinME) using fdisk /mbr, after that windows
was usable, and I think I used the tols on the install disk (9.1) to fix
grub as the boot loader.

> Anyway ... I'm done. Memtest from SuSE install DVD is running (I added
> a new memory), and tomorrow I'll be all set with a new lappy (I hope
> :) )
> Cheers and thanks for all the help

Best of luck


< Previous Next >