Mailinglist Archive: opensuse (2441 mails)

< Previous Next >
Re: [SLE] 9.3: Keyboard keymaps and xorg
  • From: AmigaPhil@xxxxxxx
  • Date: 17 Jun 2005 21:49:51 +0100
  • Message-id: <6190.29T2566T13094147AmigaPhil@xxxxxxx>
columbo (columbo@xxxxxxxxxx) wrote something I wish to comment :
(news:<200506171129.04491.columbo@xxxxxxxxxx> posted on 17-juin-05 16:29:04)

> Just curious if you went into YAST->System->etc/sysconfig
> editor->Keyboards to eliminate or identify any potential conflicts in
> your keyboard setup. Hadn't noticed in the threads whether or not you
> did.

No, but I have now.
I don't see anything abnormal in Hardware > Keyboard
Maybe I could change the YAST_KEYBOARD from "belgian,pc104" to
"belgian,pc105", but that won't help to solve the whole keyboard /
xorg / permissions issue.

In my previous post, I wrote:

> For the record, I've just receive news from the Suse installation
> support team. I can no more count on solution clues from them as
> "...the configuration of Belgian keyboards is not covered under the
> terms of the free installation support." :-((

Despite not being covered by the free installation support, someone on
the Suse team is still trying to help. :-))
Here is a paste of our recent discussion:

----- paste -----
> The rpm failures you were having would explain some (or all) of the
> problems you are experiencing.
> So, I would suggest copying the xorg-x11 off CD/DVD (if the DVD rpm
> fails then try the CD one)

I've compared the xorg rpm from the DVD and from the CD-ROM, in case
the one I used from the DVD during installation is corrupted: both
have the same size (10 743 701 bytes). I tried to list the content with

rpm --query -p xorg.x11-6.8.2-30.i586.rpm --list

But, as I read in the man pages, the -p argument make the --list only
show the files that are patched (so no "geometry" there).
However, using the KRPMView preview from Konqueror, I saw the mysterious
missing files are really in the RPM.

(Strangely (?), when I tried:
rpm --query xorg-x11-6.8.2-30.i586.rpm --state
I was told that the package is not installed. But when I tried:
rpm -i --test xorg.x11-6.8.2-30.i586.rpm
I was told the package is already installed. Confusing.)

> then, with in runlevel 3, rpm --force -ivh package.rpm may be enough to
> install it. If it succeeds then execute:
> SuSEconfig
> Now modify the /etc/X11/xorg.conf file once again.
> After that switch back to runlevel 5.

rpm failed the same way as when I tried to install the package with yast:

error: unpacking of archive failed on file
/etc/X11/xkb/compat/accessx: cpio: rename failed - Permission denied

As I was curious as to what the accessx file looks like and what are
the permissions set to, I looked in /etc/X11/xkb/compat
There are several occurences of the file (I think one for each time
I tried to re-install the xorg package), each with a ";" suffix followed
by what seems to be a checksum number. I wanted to show that list to you,
and as to easily cut-and-paste a list, I opened a terminal and run
"ls -l". I discovered something very interesting:

Linux1:/etc/X11/xkb/compat # ls -l
/bin/ls: pc: Permission denied
/bin/ls: leds: Permission denied
/bin/ls: misc: Permission denied
/bin/ls: pc98: Permission denied
/bin/ls: default: Permission denied
/bin/ls: mousekeys: Permission denied
/bin/ls: norepeat: Permission denied
/bin/ls: basic: Permission denied
/bin/ls: japan: Permission denied
/bin/ls: xtest: Permission denied
/bin/ls: complete: Permission denied
/bin/ls: keypad: Permission denied
/bin/ls: accessx: Permission denied
/bin/ls: group_led: Permission denied
/bin/ls: iso9995: Permission denied
/bin/ls: xfree86: Permission denied
total 33
drwxr-xr-x 2 root root 696 Jun 17 15:06 .
drwxr-xr-x 10 root root 576 Jun 17 15:06 ..
-r--r--r-- 1 root root 1720 Mar 22 18:29 README
-rw-r--r-- 1 root root 1184 Jun 13 23:03 accessx;42adf487
-rw-r--r-- 1 root root 1184 Jun 13 23:04 accessx;42adf4ca
-rw-r--r-- 1 root root 1184 Jun 15 10:59 accessx;42afedec
-rw-r--r-- 1 root root 1184 Jun 15 11:06 accessx;42afefa0
-rw-r--r-- 1 root root 1184 Jun 17 14:59 accessx;42b2c930
-rw-r--r-- 1 root root 1184 Jun 17 15:01 accessx;42b2c9bc
-rw-r--r-- 1 root root 1184 Jun 17 15:06 accessx;42b2cac2

Linux1:/etc/X11/xkb # ls -l
/bin/ls: geometry.dir: Permission denied
/bin/ls: geometry: Permission denied
/bin/ls: compiled: Permission denied
total 96
drwxr-xr-x 10 root root 576 Jun 17 15:06 .
drwxr-xr-x 15 root root 960 Jun 17 15:38 ..
-r--r--r-- 1 root root 983 Mar 22 18:29 README
-r--r--r-- 1 root root 7448 Mar 22 18:29 README.config
-r--r--r-- 1 root root 23337 Mar 22 18:29 README.enhancing
drwxr-xr-x 2 root root 696 Jun 17 15:06 compat
-r--r--r-- 1 root root 689 Mar 22 18:29 compat.dir
drwxr-xr-x 4 root root 424 Jun 4 23:17 keycodes
-r--r--r-- 1 root root 2401 Mar 22 18:29 keycodes.dir
drwxr-xr-x 5 root root 296 Jun 4 23:17 keymap
-r--r--r-- 1 root root 8698 Mar 22 18:29 keymap.dir
drwxr-xr-x 2 root root 392 Jun 4 23:17 rules
drwxr-xr-x 2 root root 144 Jun 4 23:17 semantics
drwxr-xr-x 12 root root 3024 Jun 4 23:17 symbols
-r--r--r-- 1 root root 31967 Mar 22 18:29 symbols.dir
drwxr-xr-x 2 root root 296 Jun 4 23:17 types
-r--r--r-- 1 root root 463 Mar 22 18:29 types.dir
lrwxrwxrwx 1 root root 22 Jun 4 23:17 xkbcomp -> /usr/X11R6/bin/xkbcomp

So in the end, it seems the files were not missing as I thought,
just "unavailable" (???)
How could it be that Konqueror is hidding files to root ?
How could it be that root is refused access to some files ?

>> (There is also these two line in SaX.log :
>> sh: -c: line 0: unexpected EOF while looking for matching `''
>> sh: -c: line 1: syntax error: unexpected end of file
>> but I don't know yet which file is causing this error.)

----- end of paste -----

AmigaPhil, world citizen. /No MS-HTML mail please/ PGP key: 0x9C07F6C1

The following garbage may or may not contain crypted message.
At least you now know I'm an advocate for the respect of privacy.


Locks only keep honest people out.

< Previous Next >