Mailinglist Archive: opensuse (3397 mails)

< Previous Next >
Re: [SLE] Managing Upgrade from 9.2 to 9.3
  • From: Sid Boyce <sboyce@xxxxxxxxxxxxxxxx>
  • Date: Mon, 18 Apr 2005 22:55:31 +0100
  • Message-id: <42642CD3.1050900@xxxxxxxxxxxxxxxx>
Michael Nelson wrote:
On Sun, Apr 17, 2005 at 05:43:24PM -0400, Bruce Marshall wrote:

Don't blame the product.... Upgrading is a complex issue.

I know that.

But I did a clean (format / and /boot partitions) install, and alsa STILL
cannot find my SB Audigy card, and hotplug/coldplug/lukewarmplug STILL can't
get anything on my USB going (most notably, my printer).

ALL of that stuff worked in 9.2 yesterday and in all versions of Linux I
have tried since installing the hardware several years ago, and it all still
works in WinXP when I dual boot into that particular septic tank of an OS.

It does NOT work in SuSE 9.3.

BTW, I'm not a newbie. I have been running Linux since I downloaded
0.98-something on floppies quite a few years back. I have seen a LOT of
distributions and done a LOT of installs, and SuSE just keeps getting worse.


Many of us hit problems upgrading and installing 9.2, including a friend who could only get a fresh install on a new HD going by partially installing XP, killling the install and then 9.2 went OK, this was repeatable. I had my problems upgrading, x86_64 laptop went through OK after many retries, x86 on this Athlon box just wouldn't, so I had to do a fresh install without reformatting the partitions. x86 on the other laptop, fresh install was OK. Since then I had to do a fresh install on this Athlon box, also OK. Basically SuSE upgrades don't seem to be the smooth operation they used to be.
I missed delivery of my 9.3 today, so my plan is to clone my drive and upgrade/install to the clone, whichever works. On the x86_64 latop my options are fewer, so I shall back up stuff to the USB IDE drive, then have a go upgrading, if that fails, do a fresh install without reformatting and restore stuff from the USB drive once I have a basic working system.
Likewise, I started with the first version Linus put up for ftp, booting from floppy, then on HD with bootlace and shoelace from Minix which I was very familiar with, though SLS, MCC, Caldera, RedHat and finally SuSE, Mandrake and gentoo, installed RedHat on SPARC and SuSE on zSeries mainframes/clones, but I never had the sort of trouble I had with 9.2 (upgrade), handled big Solaris installs and upgrades all smoothly - if ever you can imagine a smooth Solaris install, but 9.1 --> 9.2 did bring out the frustration and that was the first experience of its kind with Linux and it gets to you - the lid is very likely to BLOW! - much like with a smooth Solaris upgrade/install.
Sid Boyce ... Hamradio License G3VBV, Keen licensed Private Pilot
Retired IBM Mainframes and Sun Servers Tech Support Specialist
Microsoft Windows Free Zone - Linux for all Computing Tasks

< Previous Next >