Mailinglist Archive: opensuse (3397 mails)

< Previous Next >
Re: [SLE] FireFox broken, is SuSE Pro becoming a test bed like Fedora?
  • From: David Johanson <dcjohan@xxxxxxxxxxx>
  • Date: Fri, 29 Apr 2005 19:55:53 -0400
  • Message-id: <4272C989.3010508@xxxxxxxxxxx>
jfweber@xxxxxxxxxxxxx wrote:
On April Thursday 2005 6:51 pm, David Johanson wrote:


Likewise, this is the first time I've had YOU do any damage taking out firefox and thunderbird completly!

And for that we are all sympathetic ... but someone usually is the first one to have some bizare happening on each release.. guess you just got a pass for the next few, huh? <wink>

I sure hope so. ;-)

Still, I´ll send you some Extra Karma points, since you probably burned thru a few w/ more than one nasty word or thought whilst you dealt w/ your problems , no? <g>

Here is my solution, inelegant as it is, but it got the mail delivered.

O.K., now here is the story so far. After the disastrous YOU update, I uninstalled both thunderbird and firefox, and then re-installed mozilla. That gave me back the browser function - via mozilla, NOT firefox - but no email either via mozilla (even with mozilla mail installed) or thunderbird.

Next I did a new YOU update just for mozilla as it was shown yesterday, one day after the disaster, as a brand new security update. My mozilla self-install listed mozilla as 1.72 and the latest YOU update advanced it to 1.77, but neither provided the mail function.

I next installed gtk-qt 0.6.

I then did a new download of thunderbird and performed the command line install of that. All that appears to have provided was a huge amount of stuff in the chrome directory, but no new executable files. ;-(

Don't ask why, I'm not sure other than to say that I like poking around, but I went back to the previously used directory with the thunderbird install and tried running that again. And what do you know, it runs.

I have no idea what step of the way fixed the broken thunderbird, but it now runs just fine. Next I'll play with firefox, but the big crisis has been averted.

If you have any idea as to what might have fixed the problem I'd be delighted to know. It's not TOTALLY repaired, as I still get the following gecko errors if I start from the command line, but ONLY if I start from the command line:

(Gecko:16073): GdkPixbuf-CRITICAL **: file gdk-pixbuf.c: line 415 (gdk_pixbuf_get_n_channels): assertion `pixbuf != NULL' failed

(Gecko:16073): GdkPixbuf-CRITICAL **: file gdk-pixbuf.c: line 447 (gdk_pixbuf_get_bits_per_sample): assertion `pixbuf != NULL' failed

(Gecko:16073): GdkPixbuf-CRITICAL **: file gdk-pixbuf.c: line 481 (gdk_pixbuf_get_width): assertion `pixbuf != NULL' failed

(Gecko:16073): GdkPixbuf-CRITICAL **: file gdk-pixbuf.c: line 497 (gdk_pixbuf_get_height): assertion `pixbuf != NULL' failed

(Gecko:16073): GdkPixbuf-CRITICAL **: file gdk-pixbuf.c: line 514 (gdk_pixbuf_get_rowstride): assertion `pixbuf != NULL' failed

(Gecko:16073): GLib-GObject-CRITICAL **: file gobject.c: line 1579 (g_object_unref): assertion `G_IS_OBJECT (object)' failed

(Gecko:16073): Gdk-CRITICAL **: file gdkpixbuf-drawable.c: line 1228 (gdk_pixbuf_get_from_drawable): assertion `gdk_window_is_viewable (src)' failed


David C. Johanson
Linux Counter # 116410
Powered by SuSE Linux 7.3

People who behold a phenomenon will often extend their thinking beyond
it; people who merely hear about the phenomenon will not be moved to
think at all. -- Goethe

< Previous Next >