Mailinglist Archive: opensuse (3138 mails)

< Previous Next >
Re: [SLE] networking problem
  • From: Jon Nelson <jnelson-suse@xxxxxxxxxxx>
  • Date: Tue, 21 Dec 2004 07:53:45 -0600 (CST)
  • Message-id: <Pine.LNX.4.61.0412210750380.2785@xxxxxxxxxxxxxxxxxx>
On Sun, 19 Dec 2004, Jon Nelson wrote:

I did a SuSE 9.2 install recently on a machine with 2 nics.
The problem is that nfsserver and fam fail to start.
Further investigation shows that, despite the NICs being configured correctly at startup, by the time I can log in the NICs have no address and no route exists. /etc/init.d/network restart fixes the problem but then I have to go and restart everything that depends on network.

I've tried just about everything under the sun, and I'm at my wit's end.
I should note that the default route goes out eth1 (or what /usually/ ends up as eth1).

I currently have forsaken a routes (5) file for a ifroute-MACADDRHERE file in /etc/sysconfig/networking (if that's where it is). That didn't seem to solve the problem. I've tried marking them as hotplug, auto, onboot, etc...

When I turn DEBUG on, I can clearly see that the 'ip route ...' commands succeed (all of them).

I can't explain how, after the NICs appear to be fully set up, they both "lose" their IPs and the routing table disappears!

I sprinkled echos throughout various networking scripts like water on pavement. I narrowed it down to lines 947 through 949 of /sbin/ifup.
If I have USE_IPV6 set to "no" (sans quotes) in /etc/sysconfig/network/config then these lines get executed at boot time. For some reason, the command:
ip -6 address flush dev $INTERFACE
flushes *all* addresses, not just ipv6 addresses, from the NIC and I end up with *no* interfaces (not even lo) set up with an IP address, and thus nothing networking related works properly or at all.

Strangely, trying the same command /after/ successfully setting addresses doesn't have the same effect. I'm at a loss to explain.

Can anybody else reproduce the behavior (ie, set USE_IPV6 to no and check your interfaces after boot up. init 1 then init 3 doesn't do it)

Carpe diem - Seize the day.
Carp in denim - There's a fish in my pants!

Jon Nelson <jnelson-suse@xxxxxxxxxxx>

< Previous Next >
Follow Ups