Mailinglist Archive: opensuse (4020 mails)

< Previous Next >
Re: [SLE] IBM Laptop / tg3 / BCM5700, and no network
  • From: Anders Johansson <andjoh@xxxxxxxxxx>
  • Date: Mon, 11 Oct 2004 17:40:24 +0200
  • Message-id: <200410111740.24355.andjoh@xxxxxxxxxx>
On Monday, 11 October 2004 17.06, Neil Marjoram wrote:
> I hope someone can help me, I am a looking around to replace my current
> distro (FC2) with something a little better, I don't yet no all the ins
> and outs of Suse so bear with me.

Which version of SuSE is this? Which kernel

>
> Suse looked good.....until....
>
> I've put it onto a test laptop an IBM R40e, which has a Broadcom network
> interface (out of box kernel module tg3).
>
> The system refuses to connect to the network, an lsmod shows the tg3
> module in place, but unused. I read some notes that seemed to tell me to
> install the bcm5700 module from Broadcom, and rmmod tg3, but I can't get
> the new module to load. I have added the line :
>
> alias eth0 bcm5700
>
> to the /etc/modules.conf,

This isn't used in 2.6, only in the 2.4 kernels

> then I found /etc/modprobe.conf.local and

The fact that you have both leads me to suspect that you have 9.0, is that
right?

>
> tried that as well, with both when the system reboots the old tg3
> modules is loaded.
>
> I have tried rmmod tg3 and then modprobe bcm5700, this loads the module,

What does it say in /var/log/messages when you do this? What happens if you do
"rcnetwork start" or "rcnetwork restart" after loading the bcm5700 module?

> but the ethernet adapter is still an unknown device

Where does it say this?

> and fails to work.
> (insmod does not work - it can't find the file)

insmod needs the full path to the file, while modprobe automatically looks in
the /lib/modules tree for it

< Previous Next >
References