Mailinglist Archive: opensuse (4547 mails)

< Previous Next >
Re: [SLE] Only laptop touchpad works, not external mouse
  • From: Malke Routh <malke@xxxxxxxxxxxxxxxxxxxxxxxx>
  • Date: Fri, 28 May 2004 16:39:32 -0700
  • Message-id: <1085787572.1538.11.camel@xxxxxxxxxxxxxx>
On Fri, 2004-05-28 at 15:37, Stephen Boddy wrote:
> On Friday 28 May 2004 23:19, Stephen Boddy wrote:
> > Hi,
> >
> > I've got a laptop which is used mostly hooked up to my home network. Under
> > suse 9.0 the external mouse and keyboard worked fine, along with the built
> > in keyboard and touchpad.
> >
> > I installed 9.1 and the internal keyboard, touchpad and external keypad all
> > work fine. However I can't get the external mouse to work at all,
> > regardless of what settings I place in the XF86Config file.
> >
> > Has anyone seen or solved this?
> I've just noticed something. In /var/log/messages I get the following messages
> when I move the external mouse:
> May 28 23:31:22 linux kernel: Synaptics driver lost sync at byte 1
> Then when I move the pointer with the touchpad i get:
> May 28 23:31:26 linux last message repeated 914 times
> May 28 23:31:26 linux kernel: Synaptics driver resynced.
> The number of repetitions is somewhat related to how much I move the mouse. So
> it looks like there is some kind of conflict going on.
> I've tried to override what is in XF86Config with a PS/2 config, but it still
> only works with the touchpad.
> Just for info this is a Presario 700 (712AU I think).

Steve - I had help from this great guy, Vlad, in getting an external
mouse to work with my IBM Thinkpad. The problem is that YaST and SaX2
aren't talking. My external mouse is usb, so that's what I'm assuming
you've got, too. So here is what Vlad had me do:

Boot without the usb mouse attached and:

1.Open a console, sux to root and start sax2.
2. Expand "Input Devices" and select "Mouse".
3. Press "Change Configuration" button.
4. If there are two mice in the list, select usb. If not, then "Add New
5. Select from the left panel "USB Mouse" and on the right panel,
"ps/2", press OK.
6. Select the Expert tab and check "Enable Mouse Wheel", then OK,
Finish, Finalize, Save.
7. I had to reboot with the usb external mouse attached, but maybe you
only need to restart X by doing Ctrl-Alt-Backspace.

The odd thing is that sometimes YaST will see the new mouse and ask me
if I want to configure it when I boot up and sometimes it won't. I just
click "cancel" because everything works now and I don't want to play
with it!


"And that's how we learned our lesson!"
- Bender

< Previous Next >
Follow Ups