Mailinglist Archive: opensuse (2271 mails)

< Previous Next >
Re: [SLE] Finally got USB removable storage working with latest Mantel kernel ..
  • From: Basil Chupin <blchupin@xxxxxxxxxx>
  • Date: Sun, 25 Apr 2004 14:01:40 +1000
  • Message-id: <408B3824.8090600@xxxxxxxxxx>
dreadnought wrote:
Grrrrr .. I spoke too soon. As soon as I tried to write to my USB removable
storage at /media/sda1, I got an error that it was a read-only filesystem.
Anyone know why SuSE says this? Did I use the wrong options in my fstab
entry below?

In the meantime I figured I would burn a CD-R using k3b. Can't say I was
surprised when 3 minutes went by and k3b was still "fixating" and the KDE
desktop became unresponsive. I also tried a CD-RW and the same thing
happened. I hope SuSE 9.1 results in less hassle to get basic things

-----Original Message-----
From: dreadnought [mailto:dreadnought@xxxxxxxxxxx] Sent: Sunday, April 18, 2004 7:06 PM
To: suse-linux-e@xxxxxxxx
Subject: [SLE] Finally got USB removable storage working with latest Mantel
kernel ..
In my quest to get USB removable storage working with the latest Mantel
kernel, I installed the udev and udev-src rpm's via YaST as a member of this
forum suggested. As far as I could tell, this didn't do anything. I
couldn't see my USB removable storage mounted anywhere even though dmesg
output referred to it as "sda1" and "scsi1" .. I tried a variety of mount
commands for places I figured were logical, and always got errors.

So, I went into /etc/fstab and typed the following:

/dev/sda1 /media/sda1 auto noauto,user 0 0

Now when SuSE boots up, I type "mount media/sda1" and I can see my removable

Hope this helps someone else frustrated by this problem!

Make this entry read-

/dev/sda1 /media/sda1 auto sync,noauto,user,exec 0 0

Someone here gave me this info and it works for me.

BTW, is there a directory 'sda1' in the /media directory? (And if there are sda2 - sda4 there as well then deleted these as they are redundant - but you can leave them in if you wish as they do no harm).


I am not young enough to know everything.

< Previous Next >