Mailinglist Archive: opensuse (3470 mails)

< Previous Next >
Re: [SLE] Black screen after NVidia update - 2nd posting
  • From: Sid Boyce <sboyce@xxxxxxxxxxxxxxxx>
  • Date: Sat, 13 Sep 2003 23:32:13 +0100
  • Message-id: <3F639AED.8040505@xxxxxxxxxxxxxxxx>
I don't have as severe a problem, but with "nvidia", when I go CTRL-ALT-F1, I just have different length lines like ============ with long blue, then short red, short white, long blue. With "nv", it's fine, except I need GLX for other stuff, so I live with it.
I've just noticed that tty2 tty3 etc. have the dreaded BLACK screen, but kdm is OK on tty's 7, 8,9,11, so I can use X.

Jan Elders wrote:
On Saturday 13 September 2003 01:15, Carlos E. R. wrote:

The 03.09.12 at 23:20, Jan Elders wrote:

* cancel sax2
* goto init 5 (so, with the nvidia-XF86Config) just to try
-> black screen

Instead of that, just do "startx" from the terminal (better as user, not
root). Errors get printed on the console, and it's easier to kill. And,
"startx fwmn" or similar is faster than kde.

Hmmm, I followed your advice.
After having made changes in my troublesome XF86Config in console mode,
I did startx as user, and ....... got a black screen again.
I could not find any other way to kill this than cutting power (which I hate to do).
What do you mean by "easier to kill" ? Is there a method I'm not aware of ?
CTRL-ALT-DEL doesn't work !

When (in init 5 mode) I start sax2 from within a terminal, then I get a
normal - good - sax screen.
Then I cancel sax2, go down to init 3, and start sax2 in command mode,
and then I get the fuzzy screen again I mentioned before.

I think that is related to this text (sax2 --help) that I posted here the
other day, and that I said I do not fully understand :

[ -s | --sysconfig ]
this option tell SaX2 to import the system wide
config file even if SaX2 was started from a textconsole
which normaly will import the SaX2 HW detection

See? It seems that sax2 uses different data if started from a console or
inside X.

Well, here the -s parameter does not give any relief.
Things are going worse now. I tried the sax2 -s in console mode but when I do sax2 -s or just sax2, I don't even get the 'fuzzy' sax2 screen anymore. Now I just get some green and white scramble displayed and the system doesn't react to anything anymore.
So :
a) the -s parameter doesn't seem to make any difference.
b) I lost the 'fuzzy' screen and have garbage now. This is maybe caused by the fact that I have tried to use the NvAGP option in my XF86Config ? (without success) See my earlier posting this evening.
But after that I have re-activated my 'good' nv-based XF86Config, so where would sax2 get its erroneous information from ?

BTW : sax2 from terminal within X still works normal..


I'm getting pretty puzzled by all these nvidia driver problems. ;-(


< Previous Next >