Mailinglist Archive: opensuse (4348 mails)

< Previous Next >
Printing fun (was Re: [SLE] My patience has run out
  • From: Kevin McLauchlan <kmclauchlan@xxxxxxxxxxxxxxxxx>
  • Date: Thu, 31 Oct 2002 10:06:47 -0500
  • Message-id: <200210311006.47925.kmclauchlan@xxxxxxxxxxxxxxxxx>
On Wednesday 30 October 2002 17:42, Jonathan Cowherd
> I remember there being a few issues regarding
> network printing with BSD style lpr programs (have
> you tried lprold, unsure if it is in SuSE 8.x, will
> know this weekend when I upgrade to 8.1)?

First, thanks very much for the reply. I appreciate
the detail. My own SuSE 8.1 keeps getting delayed,
but I'm promised it is "in the mail". So, I think I'll
wait until I'm installing 8.1, to try again with
network printers.

Re: your question, I never ran BSD. I don't know
what is BSD-style or not. No, did not try lprold.
It would never occur to me that something calling
itself "old" should be better than something that a
gang of people have labored to improve, and have
compiled with modern systems. Go figure. :-)

If I see something with "old" in the name, I just
assume that it has been included for some
weird, obscure compatibility reason. So, that's a
wrong assumption?

> If you are using a bsd print system try the
> following in order:

My level of understanding is:
There's something called lpr, and there's something
called cups, and you try not to mix them, and
you hope that any automated installs (like YaST2)
know not to mix them...

> 1) ping ip of the printer. If this doesn't succeed,
> then there may be a network issue to be resolved
> first.

Pinging always worked, of course. But then, I
didn't have network problems, per se. Just YaST2,
which SAID it was setting up printing..., had a
designed in inability/refusal to look outside
the current subnet, combined with a deliberate,
designed-in refusal to accept a new ip-address range
for search.

I mean, can we truly be the only company in the
world that has employees on multiple subnets
that are not always the same subnets that include
the printers? And how hard is it to include an
editable field in YaST2, to type in an alternate
starting address for the printer/server search?

> 2) telnet to network interface for the printer, on
> HP Jetdirects it's ususally port 513.
> 3) ftp a postscript file to the printer. Not all
> network inferfaces support that, so consult your
> manual.

Ah. Never occurred to me to do that.

> 4) Check your /etc/printcap. A very basic on looks
> like:
> mylaserps|My Laser Printer:\
> :lp=:\
> :rm=\
> :rp=lp:\
> :if=/usr/local/bin/enscript-filter:\
> :sd=/var/spool/lpd/vogt203ps:\
> :sh:mx#0:

> Where is the IP of my network printer.
> :rm=<priter ip>: for "Remote" and :rp=lp: for
> "Remote Printer". :if=<postscript generator>: for
> "Input filter" :sd=<spool directory>: for "spool
> direcotry" and I forgot what :sh:mx#0: means. You
> may not need the :if=<pg>: tag if you are always
> sending postscript to your printer.

My file was entirely commented... no active lines.
That's probably due to a re-install (of 8.0) some
months ago.

I notice that one of the comments in /etc/printcap
refers to my /etc/ifhp.conf file... which does not
appear to exist on my system. At least a couple of
our printers are HPs, so such a file might have
been useful. As well, the printers that I actually
need are Canons, and there's no /etc/ifcanon.conf
file either.

Is there supposed to be such a file?

OK. Some good hints, here. At least I'll have some
more keywords to search on, and maybe recognize
what some of them mean. Thanks.

** DIR-ty DEEDS, and they're DONE dirt cheap. (Sing it,

< Previous Next >