Mailinglist Archive: opensuse (4348 mails)

< Previous Next >
RE: [SLE] My patience has run out
  • From: Jonathan Cowherd <jonathan.cowherd@xxxxxxxxxxxx>
  • Date: Wed, 30 Oct 2002 17:42:13 -0500
  • Message-id: <086DA37134977247BEAB8829B40793F56D67B9@xxxxxxxxxxxxxxxxxxxxxxxxxx>
I remember there being a few issues regarding network printing with BSD
style lpr programs (have you tried lprold, unsure if it is in SuSE 8.x, will
know this weekend when I upgrade to 8.1)?

If you are using a bsd print system try the following in order:

1) ping ip of the printer. If this doesn't succeed, then there may be
a network issue to be resolved first.
2) telnet to network interface for the printer, on HP Jetdirects it's
ususally port 513.
3) ftp a postscript file to the printer. Not all network inferfaces
support that, so consult your manual.
4) Check your /etc/printcap. A very basic on looks like:

mylaserps|My Laser Printer:\

Where is the IP of my network printer. :rm=<priter
ip>: for "Remote" and :rp=lp: for "Remote Printer". :if=<postscript
generator>: for "Input filter" :sd=<spool directory>: for "spool direcotry"
and I forgot what :sh:mx#0: means. You may not need the :if=<pg>: tag if
you are always sending postscript to your printer.

Jonathan Paul Cowherd
Linux and Java Administrator
Genscape, Inc.
Email: jonathan.cowherd@xxxxxxxxxxxx
Office: (502) 583-3730
Mobile: (502) 314-0444

-----Original Message-----
From: Kevin McLauchlan [mailto:kmclauchlan@xxxxxxxxxxxxxxxxx]
Sent: Wednesday, October 30, 2002 5:01 PM
To: 'SuSE'
Subject: Re: [SLE] My patience has run out

On Wednesday 30 October 2002 16:46, Jonathan Cowherd
> Make sure that the page spec is set to letter and
> not A4. Found that a few years ago with a HP LJ4.

I never got to the point where that would be an issue.

YaST2 never looked past the local network segment
when "searching" for printers, and there was no dialog
to TELL it to look past the nearest hub and to specify
the address of the subnet where all our company
printers live...

So, I tried setting up lpr and failed, and then tried
setting up cups... and failed... and back and forth,
several times, each time getting farther away.
I never got to the point that I could be in an
application and say "print" and have it print anything
recognizable at any of our printers (most of which are
postscript). a2ps = no go.

I got busy with real work and abandoned the effort
several months ago. Maybe I'll try again when I
install 8.1 and THAT fails to find any networked
printers (how's that for confidence? :-)

I'd be deliriously happy if the only print issue was
how to get letter-size or A4 as default.

At home, of course, there's no difficulty printing
to my locally-connected DeskJet 812.



Check the headers for your unsubscription address
For additional commands send e-mail to suse-linux-e-help@xxxxxxxx Also check
the archives at Please read the FAQs:

< Previous Next >
Follow Ups