Mailinglist Archive: opensuse (4393 mails)

< Previous Next >
Re: [SLE] New 7.3 install - java problem
I just tried the LD_ASSUME_KERNEL setting it to 2.2.5 and then exporting it. I validated it by running set | grep LD_ and it was there. I get the same message. So, the
question is whether there is something else, or is the SuSE kernel not going to let this work in this manner. I still find it strange that ANT and Jakarta-Tomcat work withou this
setting. Ah well, I guess I will be doing a lot of testing under Windows and then move the code over for Ant to install into Tomcat.

I belive you are correct, but I do not know how to fix it. I will keep reading on Google.

Thanks again.

11/15/01 10:15:38 PM, "Konstantin (Kastus) Shchuka" <kastus@xxxxxxxxx> wrote:

>On Thu, Nov 15, 2001 at 09:44:26PM -0600, James Bliss wrote:
>> Hello everyone,
>> I solved my javac problem by upgrading to the 7.3 version of SuSE. So, I would imagine that I was having a glibc problem. I installed the IBM JRE and SDK from the CD. I
>> ran javac on the sample code It comiled just fine to a .class file. Then I ran 'java JavaMemory' (without the quotes). I now get an error:
>> Exception in thread "main" java.lang.NoClassDefFoundError: JavaMemory
>> Any help would be appreciated. Again, I get this in terminal mode. I am also running Tomcat and use Ant to compile and install the code. Ant works fine and the code in
>> works fine. So, it appears to just be java in the terminal window.
>Could it be related to LD_ASSUME_KERNEL environment variable setting?
>Just search on google for LD_ASSUME_KERNEL.
>To unsubscribe send e-mail to suse-linux-e-unsubscribe@xxxxxxxx
>For additional commands send e-mail to suse-linux-e-help@xxxxxxxx
>Also check the FAQ at and the
>archives at

< Previous Next >
Follow Ups