Mailinglist Archive: opensuse (3242 mails)

< Previous Next >
Re: [SLE] Print job queued, but can't start daemon
  • From: Lawrence Sayre <lsayre@xxxxxxxxxxx>
  • Date: Sun, 30 Sep 2001 12:18:30 -0500
  • Message-id: <3BB753E6.4D59AF43@xxxxxxxxxxx>
"Rafael E. Herrera" wrote:
> It seems that you have a non-empty queue. A way to empty it is
> to use the utility "lpc". Someone sent me this a while ago, it's
> always worked for me.
> > Here is something Jim Hatridge sent me once that worked, hope it helps:
> > The big problem comes in when you have a large print job to
> > delete and lpq (the queue) says it's empty. As long as lpq says
> > it's empty lprm will not work, remember it only works on the que.
> > What to do when the queue is empty?
> > First turn off the printer to save paper and ink. Normally
> > this will not cause any errors on the monitor. You may get an
> > out-of-paper or printer-offline error in /var/log/messages file,
> > no problem.
> > Now try the lpc command. Using the "lpc clean all" command
> > with option will delete all unprintable jobs with their data and
> > control files. Unfortunately this only works if the files were
> > bad to begin with. If they are fine, you just changed your mind,
> > then we have problems.
> > The final solution is to go into the spool and delete the
> > files by hand. As root cd over to /var/spool/lpd, when you list the
> > files you will find at least 3 difference dir's for each printer.
> > There is one dir for the printer's ascii files, one for the PS
> > files, and one for raw data. Now cd to the correct dir, in this
> > dir you should find two files for each print job one fd00000000
> > and the other cd00000000. The first is the data file, ie what you
> > wanted printed and the other is the control file, ie how you
> > wanted it printed. Both of these must be deleted, "rm
> > cd00000000". While in this dir you should find a lock file,
> > delete it. This should clear your print job out of the system.
> > Now to be on the safe side, in root do "lpc restart all". This
> > will start new daemons and clear any old files out of each print
> > spool. At this point put your printer back on line. It should
> > print a few more lines, whatever was in it's buffer and then
> > stop. You will need to reset it.
> Rafael


We have a winner!!! The 'last resort' info you provided above cured my
problem. I had a huge file in my ascii print buffer, and nothing would
clear it out sans going directly to /var/spool/lpd and deleting both
portions of the file. After doing this and re-booting, printing is
working just fine again.

Thank you (and all others who stuck with me on this as well),

Lawrence Sayre

"Man's mind is his basic tool of survival!"
(a quote from the famous 'John Galt' speech
in the equally famous book "Atlas Shrugged")

< Previous Next >