Mailinglist Archive: opensuse (2425 mails)

< Previous Next >
Re: [SLE] unresolved symbols in sound.o
  • From: dproc@xxxxxxx (dproc@xxxxxxx)
  • Date: Fri, 2 Jun 2000 05:39:04 -0400
  • Message-id: <20000602053904.A5466@xxxxxxxxxxxxxxx>

On Thu, 01 Jun 2000, Paul W. Abrahams wrote:

> dproc@xxxxxxx wrote:
> > My Soundblaster 16 clone is failing to work with kernel sound in SuSE
> > Linux 6.3
> >
> > It is a PnP card and has the same pnp config as it had when it worked
> > under 5.3
> >
> > The error messages suggest to me that there is a version conflict
> > among kernel modules, which can't be right can it?
> >
> > Messages follow. Yours, dproc
> >
> > # insmod sound
> > Using /lib/modules/2.2.13/misc/sound.o
> > /lib/modules/2.2.13/misc/sound.o: unresolved symbol sound_preinit_lowlevel_drivers


> I've seen stuff like that too, and solved the problem, but I can't remember precisely
> which action I took was the key. But here are some things to try:
> 1. As root, call "depmod" or "depmod -a" (they're equivalent, but people here seem to
> prefer "depmod -a". That will fix up the module dependency file.
> 2. Use lsmod to see what modules are loaded. If your sound card module isn't loaded,
> load it with "modprobe". Also do the same for "soundcore".
> Of course, if you have a kernel version conflict, that's an entirely different
> matter.

Not quite there yet. I fixed the dependencies - thanks Paul, but now
when I try to play a sound, the modules try to autoload, and fail with
the following messages:

rplayd[6410]: connect from localhost
insmod: /lib/modules/2.2.13/misc/sb.o: init_module: Device or resource
insmod: /lib/modules/2.2.13/misc/sb.o: insmod char-major-14 failed
kernel: Soundblaster audio driver Copyright (C) by Hannu Savolainen 1993-1996
kernel: sb: dsp reset failed.
rplayd[6413]: warning: can't get client address: Resource temporarily
rplayd[6413]: refused connect from unknown

I saw a reference to this error in the archive, but I am afraid I
don't understand what to do to fix it.


To unsubscribe send e-mail to suse-linux-e-unsubscribe@xxxxxxxx
For additional commands send e-mail to suse-linux-e-help@xxxxxxxx
Also check the FAQ at

< Previous Next >
Follow Ups