Mailinglist Archive: opensuse (3222 mails)

< Previous Next >
[SLE] Re: Wine configufation



I am trying to set wine up. When I run ./configure it says
I need some X libs. I think I have installed the xpm and
Xf86 sources.
The xpm source shows up under /usr/src/packages/SOURCE as
xpm-3.4k. I don't see the XF86 libs.

Where do I find them on the install disks, or on the system
if they were installed by yast?

Do I need to create a link to let programs find them as
xpm?

If so where do I put the link?

I tried putting it in /usr/src/packages/SOURCE where yast
put the files.

I can't find the Xf86 sources.

this is the output from ./configure
<snip>

*** Warning: X development files not found. Wine will be
built without
*** X support, which currently does not work, and would
probably not be
*** what you want anyway. You will need to install devel
packages of
*** Xlib/Xfree86 and Xpm at the very least.

Configure finished. Do 'make depend && make' to compile
Wine.

I also noticed in one of the Makefile that the Xlibs are not
defined

# First some useful definitions
SHELL = /bin/sh
CC = gcc
CPP = gcc -E
CFLAGS = -g -O2 -Wall
OPTIONS = -D_REENTRANT
X_CFLAGS =
X_LIBS =
XLIB =
WINELIB = $(WINESTUB) -L$(TOPOBJDIR) -lwine
LIBS = -lncurses -lm -ldl
YACC = bison -y
LEX = lex
LEXLIB =

There is a makefile.rules as well as a makefile.rules.in
Which one should I make the changes to?


--
To unsubscribe send e-mail to suse-linux-e-unsubscribe@xxxxxxxx
For additional commands send e-mail to suse-linux-e-help@xxxxxxxx
Also check the FAQ at http://www.suse.com/Support/Doku/FAQ/


< Previous Next >
Follow Ups